High cpu usage with 192/24

I moved from moode to volumio and I got problems with 192/24 files @rpi2. CPU usage is like 70-80% and the audio cuts out time to time. CPU usage with moode is 5-10% with the same file. Rpi2 connected to avr with hdmi. System Version 2.201, mpd 0.20.6.


Hm… make sure software volume control is off and no other software based filtering/equalizing is going on.

Straight through playing should not cause such a load. Only when any sofware processing like re-sampling, etc. is going on.

Verzonden vanaf mijn iPhone met Tapatalk

It’s a clean install updated to 2.201, volume disabled, resampling disabled.

IMHO this is what happens:

  • Moode uses a newer kernel (which we just upgraded to in our test releases) which enables HDMI to play frequencies up to 24/192
  • Your version of Volumio uses a kernel where HDMI output is limited to 48k
  • Because of this, Volumio resamples your audio to 48k, with an high quality algorithm, causing the high CPU load
  • You can try the new version, and let us know if that’s still the case (see: help-needed-test-the-new-updater-t7057.html)

With v2.233, avr shows:

Sound Mode Stereo
Input Signal PCM
Sample Rate 48 kHz
Format 2/0/.0

That confirm my hypothesis, but unfortunately it seems that latest volumio still resamples to HDMI.
To be honest I never optimized HDMI since few people use it, so I am a bit lost here.
But I’ll do a bit of research and then come back to you

Thanks! I think hdmi is the cheapest option for beginners with avr and better than cheap hat/usb cards. So it would be nice to have it working.