Hifibunny driver es9038q2m i2c

has someone successfully installed the hifibunny driver for the es9038q2m on the recent new volumio versions?

@TruongVu Did you ever get this driver running on Volumio 3?
I’m currently running into the same issue :frowning:

the instructions from the driver link are for a 5-years old Raspbian/RaspiOS, they won’t work with Volumio

How can you tell it’s for an older RaspianOS?
I thought the manual was for all common Linux OS.

I get this error when I run the sudo make modules_install command:

cp hifibunny3-codec.ko /lib/modules/5.10.92-v7l+/kernel/sound/soc/codecs/
cp: cannot stat ‘hifibunny3-codec.ko’: No such file or directory
make: *** [Makefile:23: modules_install] Error 1

All steps before were no problem.

because the repository was not updated since Jan 27, 2019
since that time, several changes to all codec drivers were applied in the mainline linux kernel repo, to be aligned with changes on ALSA.
furthermore, it was recommended to compile with gcc/g+±4.9, since several years the official kernel is built with gcc/g+±8.3… if you compile a kernel driver with a different version of the compiler, it won’t work.

anyhow, those instructions were tailored for a Raspbian/RaspiOS, they were not going to work for a Volumio-based system. the error you got in the install process is the missing hifibunny3-codec.ko, that was not compiled successfully due to the reasons I explained before and due to the differences between Volumio and Raspbian/RaspiOS

Please use the custom Volumio version of the Aoide DAC, it has been compiled with a kernel that supports ES9018k2m and ES9038q2m.

Thank you @Darmur
That clears things up for me.

Thank you for pointing me in this direction.
Do you know if this will work with Volumio 3?
When I use the current version (Volumio-3.512-2023-06-25-pi) I can’t find Aoide DAC II in the list of available I2S DAC devices.

I tried with serval Volumio 2 images from the list, but they won’t boot. I get always the message ‘This board requires newer software’. I’m using a Raspberry Pi 4B.