Hifiberry Digi2 Pro with Volumio

I have a Hifiberry Digi2 pro with a Raspberry 4 to create a Volumio Player but my problem is that the Digi2 pro refuses to work on Volumio (Failed to open Alsa [alsa] Failed to open ALSA device “hw:2,0”: No such file or directory). I thought it could be a hardware problem. I installed HifiBerry Os to check and all works normaly (It’s no hardware but software). So I suppose that Volumio doesn’t accept Digi2 pro. Have you got any tips to fix this problem?

config.txt :

initramfs volumio.initrd

include userconfig.txt

Volumio i2s setting below: do not alter

Alsa config

**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 3/3
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2

Volumio Information

Volumio Version: 2.882
Hardware: Raspberry Pi 4B
DAC: Hifiberry Digi2 Pro

1 Like

I do have the same problem with my new hfiberry digi2 pro. Will there be an update that addresses this?

I have the similar set-up Pi4 w/ Hifiberry Dac Pro 2…I’m getting no audio output. I can get everything working accept that. Flashed the SD card a few times over as well.

Maybe it is again a matter of a kernel uptade that will come with a new volumio release. Hifiberry usually push their drivers to the kernel

Have you tried the Buster beta? It has a newer 5.4.yy kernel compared to the 4.19.yy kernels in the Jessie versions…

No didn’t know about it. Will try this next week and report back!

I just tried with Volumio beta-version 3.08. It now works when I2S DAC is turned off and I choose “snd_rpi_hifiberry_digi”. It also works when I turn I2S DAC on and choose " HifiBerry Digi" but it does not work if I choose HfiBerry “Digi+ Pro” (alsa error). I’d be nice to have a dedicated “DigiBerry Digi2 Pro” option though, especially since it is based on the “Digi+ Pro” and not the “Digi”.

3.080 is a broken version don’t use that one…