Hifiberry Digi - to receiver - PCM always

I’ve got a raspberry pi with a hifiberry digit. It’s is feeding a Yamaha receiver via the optical connection.

I’ve then got a stereo amplifier attached to the receiver via line out for some outdoor speakers.

Playing spotify today on volumio, I turned on the outside amp and noticed no sound coming from it…Until I switched it back to tuner. So the amp was working. I assumes it’s something the amp is receiving from volumio that it can’t pass to the 2 channel amplifier.

So my question is, is there some setting I can set in volumio, or the also config to force either a stereo output (it’s only every music) or another output mode that the amp will then be able to send as stereo.

I can also switch to a digital coax connection, if that might help me rather than optical. I never expected this as an issue when i set the volumio machine up for use.