HifiBerry Digi+ Pro: No sound on coax and no MQA from Tidal HiFi

New to the forum, to MyVolumio, to HifiBerry and to Tidal Hifi.

I installed a HifiBerry Digi+ Pro on my Raspberry Pi 3 Model B V2 today.

Problem 1:
Connected it via coax to my NAD D3045 (which supports MQA)
I get no sound…
Then I tried via optical, and it works.
(And yes, in Volumio under Settings - Playback, I have chosen the HifiBerry Digi as output :wink: )

Anything I need to do to make it send the signal via coax?

Problem 2:
I have MyVolumio Virtuoso and Tidal HiFi.
The NAD D3045 should display “MQA”, when receiving an MQA-signal.
But it doesn’t, even though I specifically choose tracks on Tidal, which have the Masters logo “M”.
I don’t see any MQA logos in the Volumio app on my Android, should I see that, when playing MQA tracks?

Any idea, why my NAD doesn’t receive the signal as MQA?

Could it be, that it’s not possible with HifiBerry Digi+ Pro?

Thank you so much in advance for your help!

mqa isn’t supported with volumio

Hello dvo,

How certain are you about this?
This user @Havel says here, that he is getting MQA signal from Volumio to his NAD D3045 (the exact same setup and hardware as mine):

@mashdk ask @volumio he knows everything…


Thanks, I guess you just asked @volumio for me :sweat_smile: :+1:

1 Like

i have read a few posts about it … but he will know all


My understanding is that Volumio does not support software decoding of MQA files, but DACs that support both first and second-level MQA unfolding will be able play them as such. @mashdk , could you try connecting your DAC directly through USB? I’m wondering if it could be the HifiBerry that’s modifying the stream before sending it out through its optical port. If that’s the case, then the MQA stream would no longer be ‘MQA’…


Thanks Patrick,

I’ll try with a USB cable tomorrow (I didn’t actually have a USB A male to USB A male cable, but it should arrive tommorow :slight_smile: )

I would think that the HifiBerry Digi+ Pro should work with MQA.

Firstly, because Havel in this post says, that he’s using MQA with Digi+ Pro and NAD D3045 (as me).

Secondly, because HifiBerry support suggested to switch to HifiBerry OS and Roon to make it work (implying that Digi+ Pro should work with MQA).

I don’t have this setup so I really can’t verify anything… Did you also disable the mixer in Playback Options, Resampling and turn off things like Volume Normalization?

Here are my Playback Options:

Output Device: snd_rpi_hifiberry_digi
I2S DAC: Off

DSD Playback Mode: DSD Direct
DSD Auto Volume Level: Off
Volume Normalization: Off
Audio Buffer Size: 8MB
Buffer Before Play: 10%
Persistent Queue: On
Playback Mode: Continous

Mixer Type: None

Audio Resampling: Off

1 Like

Alright, so I tried with USB. Volumio recognizes the DAC on the other end as “NAD USB Audio”.
But still no MQA logo on the NAD display… :thinking:

Seriously wondering how Havel made it work in https://community.volumio.com/t/mqa-does-it-work/12366/17 :exploding_head:

Sorry, scratching my head too…

Just to confirm, no equalizer plugins installed too, right?

1 Like

Thank you for suggesting things! Much appreciated!!!
Only installed plugins are Spotify, TuneIn Radio and Backup & Restore Data :slight_smile:

I’m sorry, @volumio,
But I’m going to have to disturb the All-Knowing-One :slight_smile:
We’ve given up…

1: Is it even possible to get an MQA-signal from Volumio and Tidal, when sent from the RPi via Toslink?

2: If yes, what needs to be done? :sweat_smile:

Or is Havel mistaken, when he says in the other post, that he made it work?

Sorry to disturb…

1 Like

Well, this is embarrasing!
This is VERY embarrasing…

I’ve been staring at the Playback Options on and on again and didn’t even consider looking at the Sources settings… And there it is! Clear as day: “Master Quality (MQA)” ON/OFF :roll_eyes: :man_facepalming:

And now my NAD D3045 is playing MQA!

I’m SO SO SORRY for not realizing this until now after getting so much assistance from you guys, @dvo and @patrickkfkan! :cold_sweat:

Your dac perform 1st and 2nd mqa unfolding? Because I know that volumio does not perform 1st unfolding.
I am also happy with volumio :).

I believe so. The manual says: “D 3045 include a powerful decoder and audio renderer for the MQA system”.
Which I understand to be first and second unfold :slight_smile:

1 Like

Actually, come to think of it:
Could it be, that the MQA on/off switch wasn’t available during the 15 day MyVolumio trial?
The 15 day trial ended Friday and became a paid subscription.
Wonder if that made the MQA switch appear? :thinking: