My volumio install crashed so I decide to just do a fresh install but can’t get any sound out
HiFiBerry DAC+ Pro. I can only get sound out the headphone Jack

system version 2.692

any ideas?

Select the dac during setup as output device

Sent from my POCO F1 using Tapatalk

HiFiBerry DAC+ Pro is not in the list

I see these in the list and tries all of them none work.

HiFiBerry DAC

HiFiBerry DIGI
HiFiBerry DIGI + Pro

Same version and same DAC here (HiFiBerry DAC+ Pro, RCA out) and selecting HifiBerry DAC PLUS works flawlessly.

not here…

I installed an old build and it worked again. something is not right with he latest Volumio build
updates.volumio.org/pi/volumio/2 … pi.img.zip

Sorry for the late answer: there actually is an issue with the latest 2.692 version not managing correctly the alsa configuration of the various controls of the onboard DAC chip used by HifiBerry.
Look for example at the Mixer Type and Name customizing controls in the reproduction tab of the UI: they are inconsistent.

With 2.692 running you could try to log in an ssh shell, run alsamixer and see if by chance the hardware digital volume control is set to zero by default. Alsa configuration of my DAC is a check I do routinely on every new version update and sincerely I don’t remember which situation I found last time.

Yep, 100% broken in the latest versions. I also noticed the Hifiberry site no longer posts volumio as a supported application for its DACs. As stated the old version works just fine.

I’ve noticed quite a few volume issues in the forums and with my setup.
It looks like HifiBerry has its own OS now. Might be why they don’t list volumio anymore. hifiberry.com/hifiberryos/


Same problem here with 2.729, no souind through hifiberry dac +.

Do you plan any bug fixes?


Hye everybody.
Just a follow up. I tried something the other day.
As I know HiFiBerryOS is working with hifiberry dac cards, I gave it a try. So the dac is correctly recognized and the sound is working. But playing local stored music is quite a pain. So before leaving HiFiBerryOS, i thought about copying the asound conf file. I just copied it from HiFiBerryOS and pasted it in volumio. And well it seems to work, i have sound, the led is off when not playing music.

I pasted the content into a pastebin here: https://pastebin.com/TRSRtXXE

Juste in case:

# asound.conf for exclusive audio mode
defaults.pcm.rate_converter "samplerate"

defaults.pcm.card 0
defaults.ctl.card 0

pcm.hifiberry {
  type hw
  card 0
  device 0
pcm.ttable {
 type route
 #ttable_config:stereo 0
 ttable.0.0 1
 ttable.1.1 1
 ttable.0.1 0
 ttable.1.0 0
 slave.pcm "hifiberry"
pcm.softvol {
  type softvol
  slave.pcm "ttable"
  control {
    name "Softvol"
    card 0
  min_dB -90.2
  max_dB 0.0
pcm.!default {
  type plug
  slave.pcm "softvol"

what I find a pitty, is that with this config you use a softvol on a dac with hw volume mixer…

Sure but nothing’s moving from the volumio side to better handle the bug…

On peut échanger sur messagerie instantannée en français si besoin


Sorry, noob here. I have managed to make the raspberry pi 3 b+ / hifiberry dac+pro work with volumio (v 2.729), although I had to choose hifiberry dac (not PLUS) in the configuration since the dac+pro is not available. Should this be ok, I mean, will the set up be able to make use of the dual clocks to produce low jitter performance?

Thank you very much for any assistance.

The Dac is now in the list of available DAC in the next coming version.

1 Like


Thank you very much for your quick reply! This is much appreciated :smiley: