Hifiberry DAC has no volume control

Dear all,

I have successfully installed VOLUMIO 2 but unfortunately my HifiBerry DAC does only play when I configure GenericI2SDAC and if it plays no volume control is possible? As I want to use my RPI totally remote controlled for my kitchen music I really need volume control. Anybody out there facing the same problem and found a solution?

Best regards


I have similar problem.

I use Pi3 / Volumio 2 / PiFi Digi+ (Hifiberry Digi+ clone) / Schiit Modi2 Uber DAC.
I can use Hifiberry Digi driver to make system to play music.
However, the volume control is not working. Not matter which volume I set to, the sound level remain constant.
I’ve tried to set the mix to none, reboot Pi3, set it back and reboot again. But no luck.

Strange things happened…

I installed Volumio 2 on another micro SD card yesterday.
On the same hardware configuration, the software volume control works this time.

What I did was to reboot the whole Volumio every time any setting change made.
It is annoying, but it works on my system.

However, the WebUI responsive not very well on my Mac/iPhone and Safari browser in Traditional Chinese locale.
Some times you got no response at all therefore won’t know whether the setting changed has been made. I have to close the browser and reconnect to the WebUI once again.

Dear all,

I tried now several weeks, no success till now. I succeded in installing a SoftVolume control device which works fine with speaker-test. Every time I try to connect this device to volumio (resp. spotify connect under volumio) it fails. Interesting enough that the volume control over spotify connect works (the volume is changed in the background) but as I said before my musik is only played when I directly connect the output to my HW device in ALSA (hw:0 is my HifiBerry DAC).

Any idea?