HiFi Berry DIGI+ with S/PDIF digital OUTPUT

why “Pi 3B+” with “HiFiBerry Digi+ Pro” requires Superstar plan to play sound?
I don’t use any “Digital or Analogs Input” in this setup, there is only digital S/PDIF Output - as it says in the “Digi+ Pro” manual: "HiFiBerry Digi+ Pro is a high-quality S/PDIF Output for the Raspberry Pi " Volumio device.

Also - in MyVolumio Superstar plan premium features announcement is written:
“Play anything you connect as an input to your Volumio device”.

“HiFiBerry Digi+ Pro” is NOT an input to Volumio PI 3B+ device - it’s Output.
“Digi+ Pro” is not USB turntable,
nor USB input audio card,
nor Hifiberry: DAC Plus,
nor ADC I2S DAC.
“Digi+” is simply not a DAC.

So - why “Digi+” does not play sound with Virtuoso plan ?


HifiBerry DIGI+ Pro S/PDIF output was working on my RaspPi 3B until the latest update to v2.799. I’ve been using Volumio Free. Now I get no sound since updating.

Where do you see Superstar plan is required?

Superstar plan is not required to use it… Only if you want to use inputs…
The latest update made some changes in output devices, please save the output device again and restart the system

I tried that a few times and still no dice unfortunately… any ideas?

Sorry - but It’s not true !
I have bought Superstar plan - and it works.
Neither free nor Virtuoso - does not work.
So circuits and soft is OK.
It’s definitely a question of licence…

Hi Mice,
I can assure you that Superstar is not needed at all to play to any I2S soundcard.
The fact that it works after you enabled superstar is a mere coincidence.

This latest version had some important changes to the kernel, we noticed that on some occasions to make audio output work again is required to remove and reapply power to raspberry PI.
This might have been your case as well.

What service are you using to play?

OK - I understand, but when only Superstar works and other plans not - the conclusion seems to be obvious.
Raspberry with Digi+ was hard restarted meny times and even new SD card was created from newest imege.
Stil the same. What can I do more?

I’m trying to play files copied to Internal SD card and Tidal

I am checking over here, will let you know ASAP

So, now I understood the issues I had with my audiooutput. Some big kernel changes… I’m using an PI3+ with IQaudio Digi+. Had to resetup the audiooutput and reboot volumio free. That’s it. But: never had a update WITHOUT any issues! Most I did a new install to solve them…

Which plugins you have installed? There seems to be an issue with people having equalizer and parametric eq.
Please see: No sound out of HiFi Berry DAC + with Volumio2 (2.799)

No plugins at all - pure installation.

Problem solved !
When I changed DNS from my ISP’s DNS to OpenDNS (solving other app issue) sound started playing from Volumio - even Free plan :grinning:

All in God’s hand!

Interesting! I wonder why they were related… Would it be possible to send a log to us with the old DNS?

I also was extremely surprised…
So, maybe it was a coincidence and the reason was other.
For me case is closed. In the meantime, during waiting for solution, I have moved to other RPI OS.

Sorry - but I don’t wanna public my ISP DNS.