Help with "volumio plugin install"

Hi ,
Today I tried to install Saiyato plugin for LCD but got stuck; when I run “volumio plugin install” first time automatically started to install volumio-plugin. After that I run again “volumio plugin install” and follow normal steps but at the end I don’t have a command prompt. I tried Ctrl+C and run again “volumio plugin install” but I have to follow again last steps and again got stuck.

Please , can somebody help me with that and also to install LCD plugin ?
Thank you


Hi again,

I have to return at this problem, if somebody can help.
Thank you.

Not the same plugin but similar install working process … otconnect2

Thank you for your answer , I try to do it like this but it doesn’t work ( maybe because I’m novice with Linux and Github and don’t know how to do it , you can see what I try in next pictures). First I have wget error ; I downloaded the zip file and copy it ( with winscp ) to RPi. After successful unpack when I try to install the plugin a new error appeared ( also in the pictures below ).

Please help.



After connecting to Volumio via ssh try the following:

  1. Download the plugin package
  1. Create a directory for unzipping the plugin package
mkdir volumio-hd44780-plugin
  1. Unzip the plugin package to the newly created directory
miniunzip -d volumio-hd44780-plugin
  1. Change into the directory with the unzipped files
cd volumio-hd44780-plugin
  1. Install the plugin
volumio plugin install

Thank you gvolt ! Grazie! Danke!

It’s ok now :laughing:

My pleasure! :slight_smile:

Hi friends !Need help and your hint.

  1. How to install Brutefir plugin on RASPi simply using WinSCP access ?
  2. I want to install KODI ,BRUTEFIR and Squeezelite identically to RASPi on x86/64 Volumio. Is it possible ?

This is possible, but not by using the plugins:

  • Kodi only installs on arm platforms, unless you can provide a working ppa for x86/x64
  • Squeezelite too only has support for arm right now

I did everything as described above (GVOLT)
instalation was successful
unfortunately the following appears in the volumio browser:

HD44780 plugin
This plugin is failing to start. Please install updated version, or contact plugin developer

and under settings:

No configuration available

my equipment:

Rasperra 3B + Volumio 2.457 + hd44780 display + I2c

sudo i2cdetect -y 1 is port 27 visible

does anyone have the same problem? or any solution to this situation?


That’s because the node modules need to be incorporated. You need to install the build-essential package and run npm i in the plugin directory prior to installation.

I am new to this type of thing but what does that mean
You need to install the build-essential package and run npm i in the plugin directory prior to installation.
I have tried to install this plugin and have had no luck as it tries to install and inevitably says there is no package or no modules found.
where is there a reliable place to download this plugin from?

where or what is the build essential package? and is it installed the same way.

I did the folowing to install your plugin:

[code]$ sudo i2cdetect -y 1

$ wget
$ mkdir volumio-hd44780-plugin
$ miniunzip -d volumio-hd44780-plugin
$ cd volumio-hd44780-plugin

$ sudo apt-get update
$ sudo apt-get install apt-utils
$ sudo apt-get install build-essential
$ npm install

$ volumio plugin install[/code]

The plugin is installed. Welcome message is shown on display, but the MPD info is not shown if playing. Enable MPCLCD is set to On.
If I try to start mpdlcd I get the following error:

Traceback (most recent call last):
File “/usr/local/bin/mpdlcd”, line 7, in
from mpdlcd import cli
File “/usr/local/lib/python2.7/dist-packages/mpdlcd/”, line 5, in
import configparser
ImportError: No module named configparser

Can you tell me how to corect this error? Many thanks for this great plugin.

SOLVED: Had to install Python 3:

$ sudo apt install python3
$ sudo apt install python3-pip
$ sudo apt install python-mpd
$ sudo pip3 install mpdlcd

Thanks for your sharing, so I can finish my DAC project, all I needed was the LCD screen working on the front cover of the device.
My sincere thanks
P.S. when It’s working I’ll post it here for you to see