Help with IR Remote Controller

I have spent days trying to configure an IR Remote in Volumio.

I have a RPI 3B+ running Volumio 2.729

I have separately tested the IR Receiver using an LED to confirm that it is functioning as per the test setup on this page: … -receivers

I have attached the IR Receiver (TSOP384.) to RPI Pin 1 3.3v, Pin 6 GND, and Pin 22 GPIO 25.

I have installed the IR Remote Controller v 1.2.3 and configured Apple Remote A1156.

If I SSH into Volumio and issue:

sudo /etc/init.d/lirc stop
sudo mode2 -d /dev/lirc0

I do not see any pulse / space outputs.

Can anyone suggest what I should try next…



I was able to finally fix this issue after many many hours of troubleshooting.

First step was buying a new IR Receiver which did not help.

I then triggered a “Factory Reset” from volumio.local and setup volumio from scratch.

After re-installing the IR Remote plugin, I was finally able to see pulse/space outputs using:

sudo mode2 -d /dev/lirc0

… but Volumio was still NOT responding to the remote.

Only after DL and installing a different version of the Apple A1156/lircd.conf (and restarting volumio/RPi) was I finally able to get the remote to work.

The version of the Apple A1156/lircd.conf which is shipped and installed with v 1.2.3 of the IR Remote plugin is different to the version that I DL:

I am not sure if the shipped version works for any A1156 remotes, but it does not work for all.

Can I request that future updates of the IR Remote plugin offer support for 2 versions of the A1156/lircd.conf.

My remote (shipped with an early 2009 24" iMac) has the following markings on the back:

Model A1156 EMC 2086.

Also of note is that the process of replacing the A1156/lircd.conf is not forgiving.

For example, you cannot backup the existing A1156/lircd.conf into the same directory, as it causes subsequent errors in the IR Remote plugin interface.

The system also needs to be restarted after replacing the A1156/lircd.conf and selecting it in the UI.

I’ve also had to find a similar solution due to my A1156 not working with the provided configurations. It’s worked for me up until recently and I can’t figure out a solution.

Is this fix still working for you?

Yeah, still working, but a little bit patchy.

For instance, while volume up and down DO work, prev, next and pause (that I mapped to the other buttons) did originally work, but is not currently working… I have not looked into why.