Help: Waveshare 5" Touchscreen

I am somewhat of a novice with all of this, but I have a Waveshare 5" screen that I cannot seem to get the touchscreen to work since recent Volumio update (currently running 2.692). I have followed and attempted the directions from several (all?) of the other threads, but ultimately end up with it not working. I have the following added to the /boot/userconfig.txt

hdmi_group=2 hdmi_mode=87 hdmi_cvt 800 480 60 6 0 0 0 dtoverlay=ads7846,cs=1,penirq=25,penirq_pull=2,speed=50000,keep_vref_on=0,swapxy=0,pmax=255,xohms=150,xmin=200,xmax=3900,ymin=200,ymax=3900 framebuffer_width=800 framebuffer_height=480 dtparam=spi=on

And added file sudo nano /etc/X11/xorg.conf.d/99-calibration.conf that has,

Section "InputClass" Identifier "calibration" MatchProduct "ADS7846 Touchscreen" Option "Calibration" "208 3905 288 3910" Option "SwapAxes" "0"

The screen display works fine, and the web interface works. The hardware includes a HifiBerry MiniAmp and a Mausberry Circuits switch (both installed, and work without issue).

1 Like

What specific waveshare touchscreen model do you have and how is it connected?

Is the touch functionality not working at all or “just” acting weirdly?

I have this 5":, connected with GPIO ribbon to an expansion board and HDMI.

The touch functionality isn’t working at all anymore.

PMed you.


Thanks for the DM - I’m too new to the forum respond with DMs, but I tried what you suggested and still no touchscreen functionality :angry:

Ok, please post the results of ls -al /usr/share/X11/xorg.conf.d ls -al /etc/X11/xorg.conf.d/ ls -al /dev/input cat /boot/config.txt and cat /boot/userconfig.txt
Do you get some output when you execute sudo cat /dev/input/event* and then touching the screen?

DM’d you with results.