Help needed in a Volumio build.

Hello, fellows. First of all, I must say that I’m not a Linux guy. Also, I know very little on electronics. I am in fact a biologist with some degree of soldering skills. I can, of course, follow recipes and this is what I did.

Sometime a go, I discovered that I could use a very simple computer, a RPi, to fuel my DAC/amp combo with files stored in a NAS. Cool! So I bougth a RPi 2 B and managed to get it working (not without some pain) with my Modi/Magni combo. The result was so interesting that I decided to build another Volumio box, this time to feed a microsystem. For this one I bougth a RPi A+ with an USB wi-fi dongle and no DAC for start. It worked, but I was annoyed for the lack of a DAC. Due to the actual Brazilian customs and cambial scenario, I decided not to buy a DAC, but build a very simple one. I choose the TI TDA1543A due to the very few accessory components needed to get it running. I scavenged another DAC schematics for a power source and built the TDA1543A DAC in a protoboard. When I plugged it in the i2s output of the RPi, I got no sound. After poking a little in the Volumio via SSH and WebUI, I finally got some noise, with the music faintly heard in the background . In the process, I have edited the /etc/modules, /etc/modprobe.d, /etc/raspi-blacklist.conf and /etc/asound.conf. As the system is today, with the i2s Hifiberry and sndrpihifiberry output selected, when I type asound -l, the system answers that isn’t any soundcards connected.

As an attempt to determine if the DAC was truly working, I plugged it in an old Philips CD player that helpfully used the same DAC chip and it worked flawlessly.

Obviously I have done something wrong in the process. My hunch is that is something in the Linux configuration, but I am too green to find the error.

Here some photos from the DAC.

Raspberry Pi A+, wi-fi dongle and microSD card.

DAC in protoboard. In this picture there is a wrong connection. The output caps are connected directly in the 1Ks resistors. The resistors must bleed to ground and the caps must be connected to the pins 6 and 8 of the TDA1543A. This mistake was corrected.

Using the CD player as transport to feed the DAC.

Worked flawlessly.

DAC connected to RPi. Just noise.

Can someone help me to debug this thing?

Crawling Chaos

Every Dac uses drivers that are a bit different, I would try some other drivers. Preferably search for an other full dac that uses the same dac chip and try those drivers


Maybe a clock issue? I have no clue, but maybe here:



I’ve read here at Volumio Forum and also in others sources, that the Hifiberry module works with the TDA1543. I think

the problem is that the RPi is sending data in an unsuported format. The TDA1543 works at 16bit/44.1KHz but it can

handle 24bit/44.1KHz (I think it does a downsample of the data). I tryed to use the resample tool of the Volumio WebUI

but the DAC still played noisy. I don´t know how to force the RPi to output at 16bit/44.1KHz to test if this is realy

the issue.

I don´t think it’s a clock issue either. The TDA1543 is a DIP8 chip and all the 8 terminals are being used. Three of them form the i2s interface (bit clock input, word select input, and data input). The other 5 terminals are VDD (+5V), ground, left and rigth output, and reference voltage output. To me, the DAC chip uses the RPi clock via bit clock input terminal. Also, when I connected the DAC to the CD player, using only the three i2s pins, it worked very well. But, again, I’m just a biologist.

Crawling Chaos


Crawling Chaos

Yesterday I re-tested the entire system. I tryed a lot of combinations of setings of the WebUI and of the files /etc/modules, /etc/modprobe.d, /etc/raspi-blacklist.conf and /etc/asound.conf without success.

Crawling Chaos

This is quite embarrassing. Today I found the real problem, and the fault was mine alone. In my favor, as I had already said, I am a biologist trying to understand electronics and bits and bytes. The thing is I mismatched the I2S wires between the RPi and the DAC, and plugged the word select in the bit clock and vice versa. As the data wire was connected properly, I still heard the faint music under all that noise. Yesterday I dismantled the protoboard to add an Op-Amp in the output as a possible solution for the noise. When assembling the new configuration I found the gruesome error I have made. After plugging it correctly, the DAC sang almost perfectly.