Help in getting Volumio 2 working with older browser

I’m integrating my OEM Mazda infotainment system to connect to the Volumio 2 service on RPi3 and facing some unexpected issues. I have worked through some of them, but one issue remains: the display is not consistent, and has never successfully displayed everything.

The car infotainment system is based off an old version of Opera (version 12?) and I have tried editing settings in the opera.ini file but nothing has resulted in a fully successful load of the Volumio UI. One of the attached pictures is the closest I’ve gotten, with a few button images missing, and able to interact with the touchscreen. In the other image (the usual scenario), the display is very incomplete and I can’t interact with the touch screen; there is a spinning white rectangle in the center.

I figure I’ll probably break some infotainment functions if I try upgrading or switching the browser, as the framework is tightly coupled.

Are there any configuration settings I can try for Volumio that may help in browser compatibility?

Is the screen a touch screen? If so, can you use the buttons to send commands to the websocket (that is play music, pause it etc)

This could have something to do with the network structure. Can you explain how everything is hooked up?

From what I see your browser does not support websockets…
Maybe there is some plugin for opera that you could install, without upgrading it …
BTW nice project!

There’s an old post on this relating to Opera 11 and websockets being disabled for security purposes. It also shows how to re-enable them; perhaps of some use if the problem is the websockets? … ra-11.html