Headless raspberry pi with volumio and wlan

Hi Forum
Yesterday I had found volumio and it is exactly what I was looking for. I am really excited, but with my setup I am not lucky.

I had installed the volumio img on my sd-card and tried to get volumio to run without having an ethernet connection.
This had worked previously with the OSMC and raspian installs. The light on my wireless adapter started blinking and I could connect via ssh.
For the wlan to be found I had edited the



files. That worked for both using a dynamic and static IP address.
My wireless adapter is a supported Edimax EW-7811Un.

When I try the exact same thing with volumio it does not show up in the network. The wireless adapter is not blinking at all.
Is that not possible with volumio to get it to run without having an ethernet connection at first? Any tips would be appreciated?

How can you SSH to the RPi if you have no network (ethernet not connected, wireless not configured) ?

Anyway, I would suggest you connect the RPi temporarily to the ethernet network and use the web UI to set the wireless network parameters, unless you have a special network, it should just work. Remember to type the SSID exactly.

Maybe I was not clear before:
Previously I had set up my RPi with raspbian where I could pre configure my wireless settings and that worked great to get connected to wlan immediately without the need for an ethernet network and then use SSH. I had also tried that using OSMC. Same procedure, pre configure wireless settings and only using wlan.
Now I am asking if this is working for volumio and if so, how?

I would have taken the easier way of connecting to the ethernet network, if it would be possible for me, but it is not.

You can’t connect an ethernet cable between your PC and the R’Pi? No arms? Fused fingers?

It is hard to envision a situation that doesn’t involve a physical deformity that would prevent plugging a cable into a socket.

So, ‘if it would be possible’ maybe means something else than what it means to me…

With all due respect, I think your comment is out of line. Only because you can not imagine a computer without an Ethernet connection does not mean it does not exist. Furthermore have I been writing ‘if it would be possible for me’.
With other installs for the RPi I got it to work with my setup. My question was if anyone has experience or tips.

Ah, so you want to edit the filesystem on the sd card from another computer to configure the wifi ?

On my latest Volumio 1.55 where the wifi setup was done using the web UI, I think only the following file was changed:

volumio@volumio:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
wireless-power off

auto eth0
iface eth0 inet dhcp



Thanks Sven
I have to check, but I think that is what I did.

There was also another post on the forum regarding problems with the Edimax wifi controller so I will do some tests there.