[GUIDE] Install xbmc on Volumio 1.5

Hi all!

I wanted from the beginning of using Volumio to integrate a media center with this wonderful audio player. It’s not the first try on this subjetc and you can find in the forum some. I have to state that I’m not a linux or raspian guru, although I feel confortable enough with command line to play with.

I got MPD working “under” Raspbmc and was really happy with results and quality. After that I installed Volumio and tried to install XBMC on it on Volumio with no success. You can see in that topic others got it working:


After installing Volumio1.5. on Raspberry loged as “pi” (not “volumio”) and followed Michael instructions


The only thind I added is set the user also to “pi”: editing in /etc/default/xbmc

# Set this to 1 to enable startup

# The user to run XBMC as

# Adjust niceness of XBMC (decrease for higher priority)

Volumio can play a 192khz/24bits flac fine without problems while xbmc is playing HD video :wink: ok, well, this is an experiment because I don’t need this scenario at all!! that was only a test. CPU use of xbmc when idle is oscillating from 13% to 50%, I don’t know if it is for normal although I don’t remember the bar of CPU use status jumping in that way in the raspbmc installation.

The pros: I think is very desirable to have a media player added

The cons: CEC remote is not supported for xbmc, at this moment and I have not time to try just now, coming back to iPad’s xbmc center remote…

Thanks a lot Michelangelo for Volumio!! now with more “services” :wink:

Hi there,

First of all, thanks for the guide, this is exactly what I want to do with my own Pi.

I have (hopefully) a minor problem though.
I’m following the guide, and when I want to run XMBC this is the error I get:

pi@raspberrypi ~ $ xbmc-standalone Error: unable to open display :0 XBMC needs hardware accelerated OpenGL rendering. Install an appropriate graphics driver.

I spent hours with google and with this massage, and I found a few threads complaining about it, but with no solution.

I have a suspicion at least. You mentioned that you logged in as user pi. Did you use SSH, or just the Pi with a keyboard?
Hope thats the cause of the issue, I’m installing xbmc through ssh. If so I must get a keyboard somewhere:)


Hi Wosi,

I logged as pi via SSH for sure. I needed after the usb keyboard to configure de web remote for XBMC.

edited >>>>

I logged as pi@ with psswd “raspberry” but my prompt is not “pi@raspberry” but “pi@volumio”
And also I run xbmc from startup…

<<<< end edit <<<<<

Hope this helps


Thanks for you quick answer.
Thanks to you I kept trying and didn’t buy a keyboard totally unnecessarly.
Finally I managed to get it work after sevaral failiure.

This is how:

  • first of all: I upgraded my firmwire (I belive this was the key to success)
  • I used the repository with the unstable release. Now I have Kodi Helix 14 RC 1 instead of XBMC 13.1-2. Looks ok so far,runs even smoother than latest Raspbmc.
  • It creates a file ./etc/default/kodi with the params you discribed, I only needed to set ENABLE to 1. It runs using a user named kodi which is created by default during the install (I added the input group to the system, and set up the missing groups with sudo usermod -a -G input,dialout kodi)
  • after reboot it started perfectly

Hope this helps, for those who gets the same error as I had.

Thanks again for the guide, and the help.


This is possible with openelec?? :unamused:


Thanks juanlu for your topic. I have been considering Volumio for some time, since before I got a Pi and before I tried Kodi. for various reasons I started with Kodi though, and have since wondered if I can have the best of both worlds, probably similar to yourself.

So the idea of combining them on the same Pi with a nice DAC for the audio side of things instantly appealed.

I have all of my content on a NAS box with NFS shares.

I’ve done the same as you pretty much install wise I think:
flashed Volumio 1.55 to SD, booted it, logged in as pi and followed Michael’s instructions to install and configure Kodi.
I also followed some of the instructions from this page raspberrypi.org/forums/view … hp?t=99866
(99-input.rules & 10-permissions.rules & usermod commands).

I basically have Kodi installed and running. However I am unable to browse NFS at all from within Kodi, I get no spinning wheel “working” symbol even. I know NFS client works on this build of Volumio, and on a previous attempt at getting both running I have successfully added NFS shares from within Volumio only.

Do you have any idea what might be going on? Or where I should even look for logs?
I’m wondering if it’s a users and permissions thing, but I’m a bit of a novice at Linux really so don’t have much to base that on.

Any help you can give would be much appreciated.


Still not working, but I have read up a little on Kodi logging kodi.wiki/view/Log_file/Advanced
It seems that there is a problem with libnfs.

So tried uninstalling and reinstalling libnfs4, which in turn also uninstalled kodi and mpd, so had to reinstall those too.
It didn’t fix it though.

Could the user pi running Kodi instead of the user kodi created by Kodi’s install have anything to do with this?

…there’s a fairly good chance I may have to abandon this and just buy a second Pi and DAC to become a dedicated audio box. I’d love to get it working but it’s driving me a bit insane. haha.


I’ve had this problem too, then I decided to install volumio on top of OSMC instead of the other way around.
There are still some items not working entirely, but the main reason is that installing Kodi didn’t work for me.

The problems I encountered:

  • choppy playback (even on a Pi2B)
  • no NFS support in Kodi (because Kodi uses a custom libnfs)

I did find one not entirely satisfactory workaround. By mounting my nfs shares in volumio I was able to add them as sources in kodi by browsing via root /mnt/NAS.

Unfortunately this does mean volumio has a ton of non music entries in its database.

Interesting that you say Kodi has a custom libnfs. I may try reading up on that.
Perhaps compiling from source is the correct way to achieve Kodi running successfully on top of volumio?

I’ve given up on this for now, deciding instead to dedicate the Pi to Volumio exclusively.

I’ve installed Kodi on an old android phone and it seems to run way faster than on my Pi. I’ve ordered an HDMI adaptor for the phone and will see how it goes.

But for the time being, I’m back to swapping sd cards in my Pi.

I had forsaken this quest too, maybe you can use the scripts from my Volumio 2 plugin project, you should be able to install Kodi and that version does seem to work.

github: github.com/Saiyato/volumio-kodi-plugin

and where is the manual how to install this plugin I clone it with github but no idea how to make and install the kodi built.

Hi @Tecko
If you’re on a Raspberry Pi you can just install it from the plugin store, otherwise:

  1. Install manually because you know the commands
  2. Read this repo which explains different installation options: GitHub - Saiyato/volumio-plugin-helper: Volumio plugin helper, e.g. scripts to install unsanctioned versions

In short; if you’ve cloned the repo, just remove the zip and run volumio plugin install.