[Guide] Add a ton of webradio streams to Volumio

Hi there - I’ve created a github repo, where I’m hoping to start up a large collection of internet radio streams. Here’s how to quickly add it to Volumio:

# assuming your pi is named 'volumio'
ssh pi@volumio
sudo apt-get install git
git clone https://github.com/jprjr/internet-radio-streams.git
cd internet-radio-streams
./make_links /var/lib/mpd/music/WEBRADIO/ pls

and done. So far, I have:

Most of the popular iheartradio stations
All the SomaFM stations
A few independent stations

I would love folks to fork the github repo, add their favorite stations, and issue pull requests!

Wow! Awesome! I will include this list into next version!

this is great idea!
I tried to clone it following your directions but got a 403 error: http request failed.
Any idea as to why?

Try without the https

git clone http://github.com/jprjr/internet-radio-streams.git

Yes that works, thanks!
But I still don’t get the stations :frowning: I can see the folders in the webview, but they are empty. When checking the actual .pls and .m3u files created on the pi I can see them listed nicely in the folders, but they are empty files. I see the stream and metadata on your GitHub, but on my pi neither pls or m3u contains any info.
It’s no problem to copy the files manually, but I don’t believe that was the idea? I guess there’s some issue with the scripts…
Sorry I can’t help with anything but testing(and adding more streams, when we get that far), -no experience in scripting here :question:


That is weird. I’m running on Volumio 1.4.1, I believe. Making the symlinks works fine on my end - very strange.


Glad you like it!

Yeah that is weird.
I wrote a script to create the main Danish radio stations(just changed a few things in your soma script) and it creates the files just fine, but just as with the ones created by your script, they are empty files, when opened in Sublime Text from my windows explorer. I tried to view them via nano in the putty terminal and here they actually look completely fine.

The files in /var/lib/mpd/music/WEBRADIO/danishradio (and the others created by make_links) are all symlinks that appearantly can’t be read by windows or Volumio. So I used sed -i ‘’ ** to replace the symlinks with the actual files and voila everything works and is visible even from windows.

I don’t know why this causes problems on my system and not on yours, though… Something with the setup of paths or???

Same problem here: folder added but they are empty :frowning:

Thanks for this jprjr. This worked for me. I used just these steps:

  1. Navigated to /var/lib/mpd/music/WEBRADIO
  2. sudo apt-get install git
  3. git clone github.com/jprjr/internet-radio-streams.git

That was it - there was then a folder “internet-radio-streams” in the WEBRADIO folder with all the folders and files. I pressed “Update library” in Volumio and the very large collection of streams plays perfectly.

Again, thank you kindly for this.

Listen to most popular danish netradio. Categorized as danmarks radio, rock radio, country radio, jazz radio or hør radio. You can simple select and play radios pop fm, radio alfa, radio aura, radio viborg, radio globus, radio limfjord, radio skive, nova fm, radio soft, radio ABC or radio Voice. Enjoy :wink:

Nice! Thanks a lot!

Pull request made to include the digitally imported streams.

would appreciate if anyone knows how to make them higher quality streams.


Worked fine for me.

I’m compiling list of French radio streams that I’m trying to add to a fork of your Github (first time I’m using github…)

Short question: why do you need a PLS file AND a M3U ?

Slight n00b here…resurrecing an old one…playing around with the latest Volumio and having a problem getting SomaFM streams…I tried the above, but I could not find the WEBRADIO subdirectory, so I used
and did the sudo stuff there…got the list in the GUI under MY MUSIC\internet-radio-streams with both PLS and m3u folders, but none of the streams work…

I am assuming I need to update the streams…e.g. currently, the Underground 80s m3u contains:

Are the streams still compatible?

Thanks in advance,