Greetings from Trondheim Norway

Time to register and give valuable positive feedback on the simplicity of volume and Tidal plugin.

Now I have one interface for Tidal, streaming from NAS and Internat radio, my wife loves it :wink:

Hello ArvidSletta,

I also use Volumio on a Tinkerboard (though not the ‘S’ version) with a M2Tech HiFace2.
I have always been experiencing issues with my usb DACs.
Please see: playback-configuration-lost-wrong-usb-dac-config-t11580.html

Does the same occur to you? If not, would you care to provide some details about your configuration?

Best regards

My setup worked almost out of the box, had to restart after selecting the Hiface 2 a output. After that no problems. Did a fresh install of the latest version. Du you have enough power? The Hiface 2 units consumes some milliamps, and during boot of my setup peek current passes 2 Amp for short periode.

Hello ArvidSletta, thank you very much for your help.

I tried as you described and I must say this has worked. Two reboots plus a full power-off/on cycle and no issue. Sweet :slight_smile:

My mistake was connecting the m2tech after the boot, configure it, and expect to do be able to connect it after every boot (and obviously to not need to configure it each time).
I was led to do this because of the issues I have with my other Volumio setup, which uses a Yulong D200 via USB. On that setup, I have tried literally everything, and nothing worked reliably enough. The dac is also connected to a TV via optical; not particularly relevant, but I am just saying it is shared with the tv.
So I would like Volumio to be able to use the dac regardless of the fact such dac is on or off when Volumio boots. To the current day, I have not been able to accomplish this. I ended up re-purposing a Schiit Wyrd between the tinkerboard and the dac. The only thing I need to be sure of is that the wyrd is off when Volumio starts. So I would turn on the wyrd, the dac, and everything works just fine: my dac is always at hardware index 2 (hw2,0). But it’s quite cumbersome and not very user friendly.

Of course I am not blaming Volumio for an issue that might reside in my dac. Though, I thing storing dac name instead of hardware index (hw2:0 or so) might be a lot more reliable. Just my 2 cents.

Hello ArvidSletta, I mentioned this thread on another: playback-configuration-lost-wrong-usb-dac-config-t11580.html#p60251

Your hint about the power supply has been helpful.
Still, I do not understand how your m2tech behaves so differently from mine.
Is your device the “hiface” or “hiface 2”?


Hiface 2

In my situation, I have noticed that the feature “Startup Sound” might have an effect on the situation.
Maybe if the DAC is not available at boot, this feature cause some issues. It might be random, but my issue disappeared when I unchecked this feature on both my setups.

A few days ago I tried the hiface2 on a libreelec build and discovered it was exposing the same issues experienced with volumio. So I am quite sure my device is defective, and that volumio is not culprit.

Regards and thanks

Inviato dal mio BAH-W09 utilizzando Tapatalk