getting short of patience

I have had several attempts over a couple of weeks to get Volumio working and am nearly at the pint of giving up on it.
I cant get it to find any music on my PC hard drive even though i have enabled file sharing. Am I corect in thinking that Volumio will play files stored on a windows machine as long as they are in a shared folder and I set up the mount to find them?

When I try to create a new mount it fails to work. I have tried several options including pointing to one directory specifically rather than the “Music” folder.

The error on the Volumio monitor says FSAT-fs (SDA1): Directory bread(block3840) failed. This is repeated with sequential numbers for 10 attempts/

I have then tried to find music on a USB to no avail. Nothing is listed on the USB.

Q1. is a normal Music/“artist name”/“album name”/track folder OK or does all music have to be saved out of folders in one folder?
Q2. Why cant I see the USB stored tracks (either inside sub folders or in the root)?
I really want this to work but I cant see my wife bothering to use something that is proving so tricky.

I have Volumio on UDOO Quad and Windows share connection setup worked stright out of the box using standard web interface.

I would suggest you to try tii setup cnnection manually, only few commands, see here for example … lient.html
and see what happens

The Windows share must be addressed as

Hope this can help