For Sale: Dell Wyse 3040 x86 Thin Clients with pre-installed Volumio for 50€!

Sorry but I thought it was already installed in the emmc by gkkpch.
So, if not I must prepare a usb with volumio image and then install it on emmc.
I would use it only with volumio so it s better if it starts with that by default

yes, but that part you forgot to mention, that you bought a unit form Gé :wink:
The units are set with auto dhcp, so it should find your network settings.
Download a program like Advanced IP Scanner, so you can see what is on your network and which IP the Dell was given. As long as your network mask is in it should be found.
( have 2 of them and they run flawless)

I moved these topics to the correct post, so it get’s the proper attention.

Uh, I thought I have pointed it out that it comes from Mr. Gé. Sorry again

Tomorrow I will try again to connect it and then scan the net (no pc here, will try an android app),my mask is that one.

Thank you for moving it to the right topic, would like these info to be useful to everyone if needed.

At the moment I can say the dell was well packed, in good looking conditions and fast shipped

This evening I have tried again with more time.
I agree, the dell works flawlessly. My original problem was caused by another item connected at my WiFi (a thermostat). With the DHCP the dell couldn’t find the right ip due to this item, don’t know why.
Setted it with fixed ip and my net parameters the problem was solved.
I have not tried a lot but the audio jack output seemed quite good to me.
The boot and the navigation of menu are also fast and works with no problems.

Will try to connect a net hdisk as next step, and improve the sistem with a usb dac, better cables and maybe something else.

When possible I will give other feedbacks as I use it. For now I can say that I am very happy of the choice

Edit: just a question I forgot, can I update volumio version and leave automatic updates active? Or is it better to let things as now and maybe make only some specific updates?


Yeah the little bastard performs better than expected. And with a headphone and DSP, the audio jack performs pretty well.

Thanks for reporting back!!!

Some updates

Sometimes it has false starts, I can not see the dell on the net and it needs a restart, but I am still studying why and maybe I am making something wrong.

It is…great, the dell and the software

And it is a little beast, at the moment I am downloading a torrent with my enigma decoder using transmission directly to the usb connected on the dell, that can be seen as a mount on my net.
Speed of more than 3mbit/second, and I am listening web radio meanwhile with zero problems.

Great :slight_smile:

1 Like

good morning,

still experiencing false boots, I will check better where the power supply is inserted, it is a multiplug and maybe it does not give enought power. I have read that it could be a problem in another topic. If you have suggestion anyway…

do you know what capacity of usb memory the dell can handle? Would a 256 gb usb stick works? Or is it anyway needed a powered hard disk?

I am encountering problems in mounting the hard disk plugged into my enigma 2 decoder. From the decoder I can reach the 8gb usb stick plugged in the dell, but the dell can’t do the same. I think I have solved the permission problems using cfs but it can’t see the directory (I suppose from the errore message). The hard disk is mounted in the decoder, I must maintain it as hdd anyway not as sd1. The directory is media/hdd/musica. What should I write in Volumio? The ip of decoder and parameters are correctly inserted as far as I know.

On one topic I can answer or better relate to:
The only time that I have false boots, happens if I power up by switching the voltage rail. (not using the on/off button on the Wyse 3040).

With regards to USB storage:
According the specificatons it supports up to 64GB. But this is tricky as I expect that back then 64GB was max available. Just tested with 128GB which is being read without issues.

1 Like

Still experiencing boot problems, it is reachable by net GUI one time out of 5 maybe. I have to shut it down a couple of times before it works correctly.
It happens if I close it via volumio nor with the dell on/off button.
What can I do?
I have no display, just keyboard and mouse. Do I need to buy a Displayport to hdmi cable and connect it to the TV screen to see what happens when it boot? I don’t need a screen normally but if this is the only way to have it working correctly…
When it boots volumio has no working problems

It depends on how you “cut” power, the Dell is a perhaps a bit special in that sense.
When you add power to the box (after unplugging it or after cutting power to the adapter), the start button will light up and a second or so later it will extinguish. This is normal behaviour, it is not a failing boot attempt.
You need to press the button to start the boot process, the light should stay on in this case.
If it does not, then there may be an issue

1 Like

I do it as you said. I plug it into the wall or have the multiplug button on, it does what you said and I wait also 5 minutes to avoid problems of that type.
Then I press the button but still it is not reachable from the gui at usual ip adress.
If I retry,shutdown with button and restart, it has the problem still. If I give it no power for about 5 minutes and then restart it, maybe it boots maybe same problem.
Yesterday I have plugged the keyboard after this problem and press enter, not working. I shut it down with the botton, restart and no working, press enter in the keyboard (or arrows+enter)and then it was reachable with the gui.
Today I have done the same attempt after fail with normal boot, but with no success.
When it is not reachable if I push the button it shuts down normally (sometimes not, but most of times yes)
I have plugged in and out only a pendrive with music file sometimes, nothing more.
any suggestion?

edit: I have also updated volumio as the update suggestion appeared. The problem was present before and after


when you put power to the DC plug, is the power button blinking Orange?
Are you able to connect a monitor to the device, so you can see if errors are being generated.

As i have 2 running and really am abusive to them, but as stated before, they only don’t like me if I power them via the voltage rail instead of the on/off button.

the power button always blinks white, and the same do the little light on the charger. It does as ge said, light on the charger, the button on the dell lights on and then off. After that I push it.

Have tried different ways to see if I was making something wrong but I don’t do anything that can cause it for what I understand. I am also giving power to the amp only after trying to boot the dell, to avoid possible power problems from the multiplug, I am not rude with it I think…

Will buy the displayport to hdmi cable if it can provide a solution, I am aware that it is not a stand alone 2000euro’s system and it needs a little working on. Was just trying to avoid the buy as I have no tv or monitor nearby so not planning of using it normally, but if you said kbord mouse and video are necessary to solve possible problems I will go for them

1 Like

I bought 8 of Gè’s wyses, for me and a bunch of friends, so my 2 cents.

A couple of months ago, one of the wyse’s onwer, called me reporting he had issues trying to boot his wyse. Issues were flashing light, red light and need of trying over and over to have volumio starting to run. And after a while some other wyse started beahaving like that.
Well, reason was pretty easy: the backup battery inside the wyse was low.
Since all of the Wyses I got are end of 2017 or beginning of 2018 MY (model year), the 5 year of the battery life was due.
Hope this help

1 Like

just a simple plug will do:

1 Like

thank you Giovanni, I have no flashing nor red light but if this is the case also for me I would ask a little guide or hint on how to change that battery, If possible. If you also have some information on what type of battery is needed would help me

ok whe, will get the cable and have a look at what happens when it turns on, thank you

If the battery is empty, the Dell will blink Orange for 60 sec. If it’s not doing that, the battery is still OK.


Yeah, it was acting like that (I said “red” light, sorry )


So, the battery is a CR 2032, already assembled with wire and connection. I mean something like this SHOULD BE the replacement:

I said “should be” since the replacements we got came from a computer store.

Substitution was easy, but I’ll try and do a small guide by tomorrow evening.