For Sale: Dell Wyse 3040 x86 Thin Clients with pre-installed Volumio for 50€!

RT2870/RT3070 => Works
rtl88x2bu => Works

(Seems I haven’t updated in a while, V0.001. :smile: )

1 Like

You still got some of these kickin around?

PM please with your address and I’ll return the details


I use low version numbers for locally built images on purpose, it allows you to OTA update to a regular release one.

Smart thinking. Saved a lot of hassle to roll back.
Was able to roll back via volumio updater forceupdate

Good evening, my dell arrived today. I think I need some hints now
Connected it on the net with net cable connection.
Tried to find it on the net with IP address but could not. I think net parameters are not the ones for my net ( seems quite reasonable…)
I have no usb mouse, keyboard or monitor (can provide them I think).
Should I connect it to a monitor and so, and then set net parameters? After that can I access it via browser, of the phone for example, and work from there?
What cable is needed to connect a monitor? Displayport right?

Yeah, you need a keyboard, mouse and monitor, as you need to select to boot from USB.
Dell has indeed a digital displayport.
please have a look here, there are some notes

Ok, thank you whe, I will provide what is needed.

So will it then show up the bios after start? Then I select boot from usb and from that it will always starts volumio from next bootings?

That fully depends if you always want to run it form USB, or install it to the internal eMMC. If you want to run from USB only you need to configure the BIOS as such.

Sorry but I thought it was already installed in the emmc by gkkpch.
So, if not I must prepare a usb with volumio image and then install it on emmc.
I would use it only with volumio so it s better if it starts with that by default

yes, but that part you forgot to mention, that you bought a unit form Gé :wink:
The units are set with auto dhcp, so it should find your network settings.
Download a program like Advanced IP Scanner, so you can see what is on your network and which IP the Dell was given. As long as your network mask is in it should be found.
( have 2 of them and they run flawless)

I moved these topics to the correct post, so it get’s the proper attention.

Uh, I thought I have pointed it out that it comes from Mr. Gé. Sorry again

Tomorrow I will try again to connect it and then scan the net (no pc here, will try an android app),my mask is that one.

Thank you for moving it to the right topic, would like these info to be useful to everyone if needed.

At the moment I can say the dell was well packed, in good looking conditions and fast shipped

This evening I have tried again with more time.
I agree, the dell works flawlessly. My original problem was caused by another item connected at my WiFi (a thermostat). With the DHCP the dell couldn’t find the right ip due to this item, don’t know why.
Setted it with fixed ip and my net parameters the problem was solved.
I have not tried a lot but the audio jack output seemed quite good to me.
The boot and the navigation of menu are also fast and works with no problems.

Will try to connect a net hdisk as next step, and improve the sistem with a usb dac, better cables and maybe something else.

When possible I will give other feedbacks as I use it. For now I can say that I am very happy of the choice

Edit: just a question I forgot, can I update volumio version and leave automatic updates active? Or is it better to let things as now and maybe make only some specific updates?


Yeah the little bastard performs better than expected. And with a headphone and DSP, the audio jack performs pretty well.

Thanks for reporting back!!!

Some updates

Sometimes it has false starts, I can not see the dell on the net and it needs a restart, but I am still studying why and maybe I am making something wrong.

It is…great, the dell and the software

And it is a little beast, at the moment I am downloading a torrent with my enigma decoder using transmission directly to the usb connected on the dell, that can be seen as a mount on my net.
Speed of more than 3mbit/second, and I am listening web radio meanwhile with zero problems.

Great :slight_smile:

1 Like

good morning,

still experiencing false boots, I will check better where the power supply is inserted, it is a multiplug and maybe it does not give enought power. I have read that it could be a problem in another topic. If you have suggestion anyway…

do you know what capacity of usb memory the dell can handle? Would a 256 gb usb stick works? Or is it anyway needed a powered hard disk?

I am encountering problems in mounting the hard disk plugged into my enigma 2 decoder. From the decoder I can reach the 8gb usb stick plugged in the dell, but the dell can’t do the same. I think I have solved the permission problems using cfs but it can’t see the directory (I suppose from the errore message). The hard disk is mounted in the decoder, I must maintain it as hdd anyway not as sd1. The directory is media/hdd/musica. What should I write in Volumio? The ip of decoder and parameters are correctly inserted as far as I know.

On one topic I can answer or better relate to:
The only time that I have false boots, happens if I power up by switching the voltage rail. (not using the on/off button on the Wyse 3040).

With regards to USB storage:
According the specificatons it supports up to 64GB. But this is tricky as I expect that back then 64GB was max available. Just tested with 128GB which is being read without issues.

1 Like

Still experiencing boot problems, it is reachable by net GUI one time out of 5 maybe. I have to shut it down a couple of times before it works correctly.
It happens if I close it via volumio nor with the dell on/off button.
What can I do?
I have no display, just keyboard and mouse. Do I need to buy a Displayport to hdmi cable and connect it to the TV screen to see what happens when it boot? I don’t need a screen normally but if this is the only way to have it working correctly…
When it boots volumio has no working problems

It depends on how you “cut” power, the Dell is a perhaps a bit special in that sense.
When you add power to the box (after unplugging it or after cutting power to the adapter), the start button will light up and a second or so later it will extinguish. This is normal behaviour, it is not a failing boot attempt.
You need to press the button to start the boot process, the light should stay on in this case.
If it does not, then there may be an issue

1 Like