FLAC files not playing


I have just loaded Volumio 2.413 selecting dac as DAM1021, all the setup appeared to work but when I play any FLAC file there is no volume (it shows as playing with volume at 100) - if I play DSD files (DSD256) then they are playing correctly.

Sorry cannot help you with this as I don’t have Soekris DAM to test (they repeatedly refused to provide one to the team for compatibility checking)

Oh well, I am going to try some other file types and report any progress.

Try to enable resampling, especially bitdepth. Let me know if that works

I tried another setup with the same libraries (containing FLAC and DSD files) into an iFi iDSD dac - no problems.

As per your suggestion I then tried changing the bit depth to 24 and upsampled - the DAM1021 recognised the files and played them.

One odd thing I noticed was that before upping the bit-depth / sample rate the word FLAC did not appear in the playback window within the time/rates circle; after forcing re-sampling the word FLAC now appeared when playing music.

I did find a comment somewhere that the DAM1021 likes 32-bit on the I2S input - however I have found it is happy with 24 so I will stick with that.

Thank you for the suggestion.

Also tried Spotify - only 16 bits so it does not produce music! Tried to get Spotify Connect to run - the Spotify Desktop seemed to connect but no sign of it in the menu system.

Enough for today - I will try again tomorrow.

Spotify and Spotify connect are not resampled in volumio as they not use mpd.
I’m writing a plugin that solves it, but it is not finished yet, and may not work after a reboot with i2s DAC.
But it should be fine soon… https://github.com/balbuze/volumio-plugins/blob/master/plugins/audio_interface/volgrp

Balbuze - I will have a look at that and report my findings.

ok but don’t forget is a dev version… If something goes wrong, via ssh remove the plugin folder :

rm -Rf /data/plugins/audio_interface/volgrp

Édit: do not activate the default resampling in volumio in the same time