FLAC background noise via I2S DAC

RPI B & Audiophinics sabre I2S DAC (hifiberry driver)

is anyone else hearing a background low 100’s Hz sharp noise when playing 16bit 44.1khz FLAC files?
The same song in OPUS format gives the same noise but a slightly higher frequency.
The same song in 320khz mp3 is quiet.
I tried forcing 24bit 44.1khz which solved it but found that it wouldn’t play 24bit 48khz files.
Tried all the sync interpretators - all with same result.
Thought about downgrading to 1.51 but not sure which repositories to look in.

I know that problem and I’m talking about it here : volumio-plays-high-resolution-files-warp-speed-t2078.html
and testing-needed-for-i2s-dacs-t1958-40.html . but I haven’t done a test with Volumio 1.55… I have to reassemble my first project to test it. It will take serveral days… :wink:

1 Like

Sorry Balbuze i didn’t see those posts. Glad to see i’m not he only one who has the problem. I really don’t want to reflash as i’ve hacked the Pi into a 1960’s Bush radio and means taking the back off etc!
To bo honest i had not noticed the noise until i finished my 12x LM3886 chip amp, now it’s really noticable especially just after you press play before the music starts. Also the sound of the 16bit 44.1 files seem worse quaily than any other format.
Is this specific to the Audiophonics ES9023 or are the others the same? I get the noise using all the other I2S drivers too.

Hi !
I promised, I did some test with my previous dac audiophonics ess9023 . With Volumio 1.55 I get the same noise than you (I think) asap I press the play button. I’m sure than with Volumio 1.4 it was ok :frowning: . So I don’t know where the problem comes from, but I confirm you’re not alone :confused: :confused:

Any progress with this issue? Beginning to loathe the 16 bit 44.1khz flac tracks coming on :cry:

To be sure, I have reflash a Volumio 1.4 image and the verdict is that it sounds cristal clear. But unfortunatly I still don’t know what is wrong…

I came back to Volumio 1.55 with it hiss with 44,1/16 flac file.
So, I resample 24b/44.1Khz and best sinc interpolator and now it is clear with all the files I have tested. CPU load is <10% except for a 24/48 and above > 95% … But most of collection is 16b/44.1 :wink:

Yeah I did this and yes it works for the 16bit 44.1 files. But try to play a 24bit 96khz file and it won’t play, stuttering like someone playing the bongos!
I might try up sampling higher to see if it’ll sort that out.

I have exactly the same problem in version 1.55. I tried everything, from playing via USB, NAS, testing different kernel profiles, but the problem remains. Is somebody know any solution for that? I really dont want resampling…

Oh, and I forgot to write, i am using hifiberry digi and external DAC. I connect dac via Digi using coax cable and via USB. Background noise is there in all cases. The DAC is OK, I tested it on laptop with the same songs.

No news yet I’m afraid. I’ve even tried updating MPD to version 19.9 and recompiling.
still the same result. So I’m guessing it’s a kernel based problem.

Well I tried volumio v 1.4 also an it works without that anoying hiss…But that is not the solution in my opinion. What about rune audio? Is there the same problem?

posting to follow…

Yesterday I tested volumio v 1.55 with raspberry 2 and the problem persists… When playing FLAC files and even vhen playing mp3 files.

Same problem here with playback of 24bits 96kHz Flac files.

Using also Volumio 1.55 on the raspberry 2 with Hifidigi and an external dac.

Hope to see this issue fixed in the next release…

Well I have found a solution to the problem.
I added a preamp with its own volume control, disabled volume control in Volumio and would you believe it no more background noise.
Not an ideal solution but looks like we’ve norrowed down the cause.

So it looks like there is a problem with SW volume control? Can someone test HW volume control? I cannot, becouse my dac does not support that… But SW volume control was OK with version 1.4, so it looks like 1.55 version brings us corrupted volume control…

Another factor to consider is that as far as I can tell, everybody reporting this issue is using a new Raspberry Pi 2 B instead of a old B or B+ model. So it also could be something that is introduced by using a newer ARM v7 kernel. I doubt if anyone testen a ‘working’ 1.4 on the new Pi 2 B.

Myself, I am using 1.55 for quite some time now on a ‘old’ B+ with a HifiBerry Digi+ (and external DAC) and I am not experiencing this issue. I have a new Pi 2 B which I hope to setup shortly and than I will know if I might be affected by this issue as well (the Hifiberry Digi+ also uses the I2S interface to generate its SPDIF signal, so it could be affected in the same way).

No, I am using raspberry pi B (not +) with hifiberry digi. When I mount volumio v 1.4, there is no noise, with version 1.5 or 1.55 there is noise. On raspberry 2 with usb dac the noise still persists. So I think there is a problem with volumio`s volume control.

I originally had the problem on an RPI B (256mb) using (hacked) I2S output. Upgraded to the new RPI 2 using I2S - exactly the same noise.
DAC - Audiophonics Sabre ES9023 using the Hifiberry driver.
Volumio version 1.55
Personally I believe its a software / driver issue as I’ve proved disabling the software volume control completely eliminates the issue.