fixed IP address for wifi


I downloaded the latest version of Volumio and configured the rpi using the lan interface
–> fixed IP address etc --> works fine
configured the wlan but there I cannot change the setting for dhcp
on the first configuration there is no selection possible as nothing is showed
after restart (disconnected lan) it shows dhcp not selected … and it gets a DHCP address

I would like to use a static address for the wifi (not possible to pull cables)
where can I change the setting for the WLAN ?


You should edit the /etc/network/interfaces file and add the following lines

allow-hotplug wlan0 auto wlan0 iface wlan0 inet static address your-static-ip netmask gateway your-gateway-ip wpa-ssid … wpa-psk …
then reboot and everything should work fine.

You have to do it manually…
Login via SSH (user root and pw volumio)


nano /etc/network/interfaces

find the line

iface wlan0 inet dhcp

and edit this way

iface wlan0 inet static

Then, add the following after that address (the ip you want) netmask gateway (your routers ip, usually )

save with ctrl+x and reboot

it shoud work!

Let me know!


worked flawless :slight_smile:
sometimes it is necessary to go back to the basics and open de files with “sudo nano …”
as I actually made a mistake in one line (missing character), I took the SD card and edited the file through my PC (linux mint 13)
Now it says it was edited outside the RPi but that is OK :slight_smile:

again thanks


I installed the wicd-curses via ‘sudo apt-get update’.
Afterwards connectivity is easy to set up. Static IP’s are no problem.
With this method I’ve implemented wlan and wifi connection in addition.
For each connection to choose I’ve copied reading marks with adequate connection links to the smartphone’s screen. Although wifi I’ll only activate in mobile conditions, so I’ve installed volumio on a second sd card where only wifi is prepared.
On the other card ethernet or wlan are selectable for every day home use.
Works quite good for me.


I cheated a bit by setting the static ip on my router. Entered the mac address for the wifi dongle and chose ip address I wanted. Not so elegant, but worked a treat.
Enjoy listening.