First Volumio Streamer Issues

I’ll start off by apologizing as this is my first ever forum post and I’m a complete newbie with Volumio and Raspberry Pi’s. Any help would be greatly appreciated!

The Raspberry Pi 4 is my first network streamer and when it works it works great. I got the streamer up and running with a few hiccups but now I’m starting to see issues almost every time I use the device. For example, I have connected Volumio to my Spotify and Tidal accounts and I have local music downloaded to the SD card but it’s hit or miss as to if I get audio out of the device. Usually first I’ll try Tidal connect to get music playing out of the Pi, I go into the Tidal App, use Tidal connect to talk to Volumio, and sometimes it connects no issues, sometimes after I click connect, Volumio disappears and it won’t find it again. If this happens, I’ll head over to Spotify to use Spotify connect with the Pi. Nearly every time I have issues with Tidal I’m also having issues with Spotify as well. It usually does the same thing, it recognizes Volumio, I connect to it, it will spin for a minute trying to connect to the Pi, and then give up and Volumio disappears from the list of available devices. Sometimes I’ve had success going into MyVolumio and then going to Spotify/Tidal and playing music but this is also hit/miss. Next, I’ll try playing music I’ve downloaded to the SD card and 9 times out of 10 when I select a song for the Pi to play I get this error message “Failed to open “alsa” [alsa]: Failed to open ALSA device “softvolume”: No such file or directory” and it won’t play any tracks. This happens on both DAC/AMPs that I use - I’ve tried A/B testing and it appears to happen to both for any/all reasons.

The only way I’ve figured to get around this is to wait…shutting the Pi on and off multiple times, logging in/out of volumio, and lastly changing up the inputs (USB to HDMI to headphones). Sometimes each of these fixes work, sometimes they don’t…there’s no predictability.

Any suggestions from anyone as to how to fix these issues? I’m so frustrated that I’m ready to return the whole set up and get my $120 back…

Volumio Information

Volumio Version: 2.907
Hardware: RPi 4 8Gb, 32GB Samsung EVO, CanaKit 3.5A USB-C Raspberry Pi 4 Power Supply with Noise Filter
DAC: iFi Zen Dac V2 and FiiO K5 Pro - both connected to the Pi via USB
Network Setup: Using WiFi to connect to the internet as the Pi/DAC aren’t near an ethernet port in my house.

I don’t have a screen hooked up to my Pi so I can’t see the software running aside from connecting to the Pi on my phone/computer.

Are the two DACs always together connected?
I have had issues when f.e. my Topping and my ZEN are both connected and I always changed before in Volumio.
These issues disappeared as soon as I gave the ZEN his own PSU.

I’ve had the issues when they’re connected together and when they’re each connected separately.
In order to fight the Zen Dac’s channel imbalance issue, I’ve had to force Volumio to handle the volume control and doing so fixes the channel imbalance but doesn’t allow for any MQA files to be sent to the DAC…Looks like it’s only sending PCM :frowning:

Also what is a PSU?

Power Supply Unit. The ZEN works without but I have had a matching gear here. No idea if there is a coherence.
And I tried with 100% Volume and got the led lighting in green or blue on the ZEN DAC V2. (And I think this should proove, that an MQA signal is delivered to the DAC.)
With less than 100 I got yellow for CD quality…
The magenta light I get only via Audirvana.

Got it.

Yep Volumio will send MQA to the DAC, which I’ve seen on mine but then I have to deal with the channel imbalance :frowning: To overcome this, I have to manually set the volume on volumio which stops the MQA from getting spit out. Sounds like both of us are having the same thing happen!

Any suggestions as to how to fix the bugginess though? I’ve already started a return on Amazon for the Pi as it’s so frustrating to constantly have to have connection issues with the DAC.

I am really not so deep in this. I know the Pi only since maybe 6 months. So I had to be in my late 60s to discover this tiny gimmick. And a few YT vids brought me to try and have a little play. It is a “project” for an old man with lots of time. My everyday gear takes all those sorrows away from me. But the costs are highly above a Pi, a case and one or two DACs.
So, my knowledge about that is very small and I think I cannot give help…

1 Like