Failed to open ALSA device confusion

Volumio Version:2.907
Hardware: RPi-3; USB Hard Drive; cable connections (no wi-fi).
DAC: USB-Schiit Modi 2

Everything worked fine yesterday with the same version #.
Today, after checking (& saving) the start-up sound which had mysteriously disappeared some days earlier.
Nothing would play - Stored music or online pod-casts
Error message - Failed to open ALSA device “hw:5.0”: No such file or directory

In the “Output Device” drop-down box the USB Audio option disappeared. After a re-start the “USB Audio” option came back, but disappeared the moment it was selected leaving “Headphones” & “HDMI Out” as the only options.

Third re-start & it all started working again !!!

Any thoughts? - other than “Don’t turn it off” !!!

Could it be the power supply starting to fail and therefore not always outputting the needed voltage to power the DAC?

Thanks - I’ll try swapping that out - although I would expect to see some errors from the R-Pi & the HD. The HD has not had any access problems via the network.

The problem isn’t the power supply nor any of the cables (all replaced).
The USB-Schiit Modi 2 DAC works with my PC.
The Volumio software seems to work for everything except that it doesn’t recognize the USB DAC.
(This is now seems to be a permanent problem - re-starts do not work.)

Another audio boat anchor to add to my collection !!

I see no log being produced here, please create one.
It might give some more info about the behavior of the usb port where the DAC has been connected to. Google the internet, there are several reports.
Did you look at the Schiit Guide?

Sorry for the slow response - I am not very experienced with Volumio/Linux code & would struggle to find the log file that you would need.
I eventually bought a new Schiit Modi 3 and, together with all the other old pieces, Volumio worked again.
The old USB-Schiit Modi 2 DAC works with my PC & my current feeling is that a recent Volumio update dropped support of my Modi 2 (which had been working well for many years).

It’s not very involved, can be done with a few clicks!

Would you share some system logs please?

Preferable from a fresh reboot, with minimal steps to reproduce the problem :slight_smile: