Experimenting with Low Cost DAC

I have Volumio running successfully in a Raspberry Pi (model B) and I’m streaming from iTunes successfully using Airplay. Everything is fine if i use the Pi’s on board audio output but I’m sure sound quality will be improved with a USB DAC. As an experiment I have tried the following cheap device, I don’t want to spend too much on a ‘proper’ one until I know it will work:


I have used it successfully on a self-build Pi with Shairport but I can’t get it to work with Volumio. All I get is highly distorted sound from the DAC, no amount of tweaking with volume levels or any of the playback options on the web UI make any difference.

This is a popular low cost DAC, has anyone else any experience of this?

Try these steps:

1-Change PI’s power supply
2- Select software Volume control
3- Activate resampling (fastest) to 16/44

Let me know


Thanks for the quick reply. I have tried everything you suggest but this makes no difference. The power supply is 5V 1.2A, I have tested the voltage on the Pi and it is 5.15V. I have tried alternative power units but there is no difference. I have altered the playback settings as you suggest, no difference.

I have changed to another Raspberry Pi, using the same SDHC card, all the power supplies and the same DAC. No difference.

I don’t think it can be a faulty DAC as this one works OK using another software build (Raspbian and Shairport).

Hi again,

Further investigation, the USB DAC is a C-MEDIA ELECTRONICS INC CM108 device, a summary of the features is at:


The Datasheet for the product is at:


This DAC is sold as a low-cost device by many sellers on eBay and there are variants on Amazon and other online stores. The performance is not top-class but better that the RPi on-board DAC. For less than 2 Euros / 2USD I would think it a good choice for people looking to build multi-room systems, using a top grade DAC on their main system but cheaper options in areas where 100% quality is not needed.

I have this exact device, in fact I have two on two different Rpi’s both work very well with no distortion. Have you tried playing with sudo alsamixer.

The DAC works perfectly when used with a standard Raspbian build
On Volumio the DAC is correctly listed
I can play music through the DAC, but It’s distorted. Changing volume levels in alsamixer has no effect on distortion, it just increases and decreases the volume.

Which parameters are you suggesting I change? Could you publish the configs you are using please?

The only changes I made were in the webui under settings, I changed Audio output to Device and Mixer type to Software.
Could it be your network ? I would say a power issue but I have one powered direct from the PI with no distortion.

After much searching I found a partial solution on Adafruit. I started afresh with a clean install of VolumioBeta1PI on a new SDHC card (10G, Class 10). Once running I did the following:

Boot the Raspberry Pi with the USB DAC plugged in, then list USB devices

$ lsusb

This reveals the USB DAC is a C-Media Electronics, Inc. CM108 Audio Controller

Update the package list

$ sudo apt-get update

Accept the notification on disc space, then once completed install the following

$ sudo apt-get install git-core $ sudo wget https://raw.github.com/Hexxeh/rpi-update/master/rpi-update -O /usr/bin/rpi-update $ sudo apt-get install binutils $ sudo chmod +x /usr/bin/rpi-update $ sudo BRANCH=next rpi-update
Edit the alsa configuration

$ sudo nano /etc/modprobe.d/alsa-base.conf

Change the line: #options snd-usb-audio index=-2 to be: options snd-usb-audio index=0, then Close and Exit (Ctrl O, Ctrl X).


$ sudo reboot

Music now plays through the USB DAC without continuous distortion, fidelity is better than the on-board audio output. There are occasional stutters and clicks, I’m still working on the UI settings to see if these can be eliminated using the settings. It is not perfect but I’m moving forward. I am happy that the power supply is not an issue, I am using a 5V, 2A Apple iPad charger with an extremely large capacitor added, to remove ripple and provide some ballast.

Sorry if these instructions are not laid out following any particular convention but i think they should be easy to follow.

Now I need to investigate CIFS sharing as I can’t reach the Music directory on my NAS…

i used USB 2.0 Mic Speaker 5.1 Audio Sound Card Adapter before, and i also had this problem, :frowning: , i tried everything, but it does not work, so i give up.