Ethernet Not Workling With Latest X86 Release on Dell Laptop

Hello, I seem to be having issues getting my Ethernet to work on my dell laptop running the latest version of volumio. I would consider my self a power user, so i know my way around the computer and what is odd is that i am not getting any connection from my computer to my router via Ethernet, I have verified the cable works and all. Wireless does not work as well.

did the previous version work?

No luck so I assume it’s device specific, I’ll give the exact laptop specs when I’m back home.

It’s a Dell latitude e5470. Any suggestions?

yes, try the versions as announced in this thread
It is not finished yet, but should at least give an idea whether your HW is going to be supported with it.

Sure thing, I love to beta test anyway lol. I’ll let you know probably later in the day tomorrow.

I can confirm this is a software issue as this beta version is working!

One odd thing though, it’s showing my network as 10Mb/s but a full end to end 1Gb/s set a up

Update: after setting dev mode on and doing OTA update it shows as 1Gb now

Where does it show this? In the network page?

Correct it did at least did the first boot. I’m in the middle of testing the latest OTA again as I thought It worked the first but it’s my second attempt as I thought it went fine the first try but oddly settings new settings and features that were broken with the latest version that was on then debug pages worked however it prompted to update again. The other thing if could be is that it’s a second new updates that was depending on the first.

Another update that Ill post in the main beta forum, sources are acting odd. It keeps detecting my hdd as a usb drive and not recognizing my usb drive at all. I have tried a few different drives formatted different (NTFS and exfat) ways with no luck. Sometimes it will not update or re-scan as well and if i try to go to my music library noting will show up at all.

To be be investigated…