Error trying to play BBC radio streams via MinimStreamer

Running Volumio v 2.457 on a RaspberryPi B+. MinimServer & MinimStreamer running on both an old QNAP TS-109 and a newer HS251+. Until very recently Volumio happily playing BBC radio eg #EXTINF:-1,[R3;aac,48000] BBC Radio 3 day in / day out from the TS-109 and occasionally from the HS251+, activated either from Volumio’s web interface, or BubbleUPnP by choosing the relevant instance of MinimServer on either NAS as Library/Server and finding the radio playlists in the form exampled above.

A few days ago the TS-109 started to play up (amazing it’s kept going this long!) so I switched to the HS251+ for my regular source, only to get error messages. On the Volumio browser interface the pop-up error message (after an initial green ‘Started Playing’ pop-up) is:-
“Failed to decode http://*/R3$1/$!stream.aac” (With BubbleUPnP I get a similar momentary appearance of starting: ‘play’ icon changes to ‘pause’ icon, but no sound, followed almost immediately by reverting to ‘play’ icon.

If I try a different stream source, eg #EXTINF:-1,[*R3] BBC Radio 3
I get the same behaviour with a slightly different error message: “Failed to decode http://*/*2aR3/$!transcode.wav; CURL failed: The requested URL returned error: 500 Internal Server Error”

A couple of years ago I was having similar - but not identical - problems trying to play the UK BBC HLS streams, which finally got sorted with help from the MinimServer developer. Since then I’ve been careful not to change the system properties in MinimServer, but when I ran into this problem I did try removing the “stream Size=4gb” from MS’s stream.options field and “*:wav” from sream.transcode (these had solved the previous problem playing on the earler version of Volumio) but it made no difference. However, I have updated Volumio since then - in fact made an entirely fresh installation, and it’s possible (though unlikely) I’ve not attempted to play the streams from MinimServer on the HS251+ since that re-installation.

How do I go about troubleshooting this issue?