Error: Failed to Open Audio Output

Configuration: Volumio 2.118 rPi3+Kali+Piano 2.1

I get the subject error message when I try to play any track on the above configuration. I just switched from a usb dac to the Kali+Piano 2.1. I upgraded from version 2.001 to 2.118 and was having issues with the usb dac, but finally after numerous restarts was able to get it to work ok. Things really became erratic when I installed the Kali+Piano 2.1. Out of frustration, I reformatted the uSD card and did a clean install of 2.118. I reconnected the usb dac and everything worked fine. Then I retried the Kali+Piano 2.1 and got the same error message above. I contacted support at Allo 2 times and received no response so I am hoping I can get some help here. My other player is operating fine on version 2.118 on a Pi3+Kali+Mamboberry LS.

I know nothing of Unix and am not comfortable editing code lines.

Any suggestions?

Hello KeithG,

try the following version 2.130 out.
Is especially for Allo but not yet official


I apparently received a defective power supply from Allo.

My first suspicion come when I removed the Kali from the stack and used the Allo PS to power the rPI. It worked but there was a tremendous amount of noise along with the music. I ordered a 5V iFi low noise PS to try since I still have not heard back from my messages to Allo Customer Support.

I swapped that for the Vilros PS I was using and was amazed at the sound impovement. I am still on Volumio version 2.118 that was not reported to have issues with the Kali so I just installed that and started up again. Again there is noticeable improvement This time the improvement is in the top end with much cleared definition of cymbals, brushes. Right now I am very happy with the sound I am getting.

Thanks for the help provided to solve this issue.