Error "Failed to open alsa"

I’m attempting to get Volumio on a Raspberry Pi (3B) to output via it’s native USB to my PS Audio Sprout.
I’m not sure if this is possible?

I previously tried to use Volumio with an Allo USBridge. However, the Allo USBridge would not detect the Sprout, so I returned the USBridge. Now I’m trying to see if I can get just the RPi’s native USB to work.

Volumio sees the Sprout over USB - so I have that set for playback. The Sprout supports DSD files via DoP - so I have that set in playback also.

But, when I attempt to play any kind of file, I get “Failed to open alsa Error opening ALSA device hw:5,0; snd_pcm_hw_params() failed: input/ouput error”

I even tried putting an iFi iPurifier2 in between the RPi and the sprout - no luck. I’m also using a iFi iPower power supply and an Audioquest USB cable.
I’ve uploaded the log:

Any ideas? Or am I barking up the wrong tree here?

It appears the issue isn’t with Volumio, but the PS Audio Sprout. PS Audio has confirmed they have an issue with the USB input interfacing with the Pi or linux.