Error failed to open alsa device "hw:2,0" : no such file or directory

Hi everyone,
i just built my first Volumio based system.
I started with a Labits Raspberry Pi 4 model B Kit and an HifiBerry Dac+ Pro, downloaded Volumio latest version, flashed the card and …
The system is working fine as i play music (form an USB card) choosing headphones as output.
The problem comes enabling I2S DAC.
I enabled / disabled DAC many times, powered off / rebooted system but nothing, the issue is still the same.
As i click “play” on a song i got the same error message.
Thanks in advance for help!

Volumio Information

Volumio Version: 2.882
Hardware: Raspberry Pi 4 Model B
DAC: HifiBerry DAC+ Pro

This is a typical, if not all that clear of a message you got. Basically, wrong dac selected in the list or a not supported dac and there is nothing for alsa to output to.

Try the generic Hifiberry dac in the drop down list.

I tried choosing different Hifiberry models from the list and even generic I2S DAC.
No way, still getting the same error

take a other version…2.882 seems to have a lot of errors… try the 3.xx version

1 Like

Works fine here: Pi4 4B 2GB, HifiBerry Dac+ Pro, Volumio version 2.882:

Faulty DAC?

Are the DAC pins properly seated in the Pi header? Is the power supply a 3A one?

The Pi and DAC are well boxer inside an Hifiberry steel case.
The Power supply is 0.5A Max …

ain’t you under powered ? i agree with @dheijl 3 amp is what u need.

0.5 A : this can’t be right, but if so, where did you get this power supply? The bare Pi alone needs 0.6 A :

The Power supply was included in the Labits kit, here Is an


That is 3A OUTput

lol he was telling the wrong info your right it’s: 5.0v / 3amp /15 watt

Sorry guys, so the PS Is ok, what else should i check?

yess, tell us what you tried and post a log file with that we could figger out what’s happening…
Send Log or bug report first, say what the problem is after that press send,
and post the link you get here.

try to set it like dheijl has posted:
under: settings >> Playback options >>
i2s dac ON , and select HIFIBerry DAC+ Pro
and save

Here is the link to log file, thank you very much for help guys!

did you set the settings in play options … i don’t see your hifiberry…

It looks like the hifiberry is not detected…

One thing I would try is to flash a fresh image of Volumio on a different SD card, then redo the setup. If you don’t have another SD card, do a reflash and start again on your current SD card.

And, I would also make sure the dac is installed firmly onto the pi.

Hey guys i finally fixed It!!! Volumio Is up and running with DAC properly working :wink:
The problema was incorrect connection within Pi and DAC.
Not my fault, the Hifiberry steel case had the two componente not to stay properly aligned so only half of the pins were connected … :sob:

Thanks everyone for help and … Pay attention to this case, had to fix It with brute force!