Error connecting to Xserver Touch Display blank

I’m getting the “Error connecting to Xserver” and my original 7" raspberry touch screen is blank.
I’ve already reseted the volumio using factory reset and successfully reinstalled volumio touch display plugin, but I still get this error.

System Information

OS info

Version of Volumio: 2.909
Hostname: volumio
Kernel: 4.19.118-v7l+
Governor: performance
Uptime: 0 days, 0 Hrs, 4 Minutes, 33 Seconds

Audio info

Hw audio configured: X1S USB DAC
Mixer type: Hardware
Number of channels: 2
Supported sample rate: 44100 48000 88200 96000 176400 192000

Board info

Manufacturer: Raspberry Pi Foundation
Model: Raspberry Pi 4 Model B Rev 1.2
Version: c03112
Firmware Version: Apr 27 2020 14:33:37 - 3a8f1793b758d6fb7f375edaa260e069ecd34c88

CPU info

Brand: Processor rev 3 (v7l)
Speed: 1.5Ghz
Number of cores: 4
Physical cores: 4
Average load: 86%
Temperature: 64°C

Memory info

Memory: 4044912 Ko
Free: 2276144 Ko
Used: 1768768 Ko

Storage info

INTERNAL storage - Size: 12097Mo
Used: 350Mo
Available for storage: 11111Mo (92%)

Probably the download of packages during the installation of the plugin failed somehow.

I suggest to uninstall the Touch Display plugin and re-install it.

P.S. Did you wait several minutes after the first boot of Volumio so the data partition got fully expanded? If not, you could connect to Volumio via SSH, execute

touch /boot/resize-volumio-datapart

and do a reboot before you try to re-install the plugin.

1 Like

Hello, I have an interesting error when trying to install this package (3.3.2)

Everything goes OK until it gets to the keyboard configurator. It asks for an input to select the keyboard language and stops. I don’t know how to give it the input it’s looking for. Eventually it times out and ditches the install.

Should I try 3.3.5?

There is no input to be made during the installation of the plugin.


Thanks, that worked.