Error adding network drive (SMB)

I’m trying to add a network drive and get the following errors:

[20-Feb-2015 21:40:13 UTC] >>>>> mount string >>>>> mount -t cifs "//" -o username=gonace,password=***,rsize=8048,wsize=8096,iocharset=utf8,ro,dir_mode=0777,file_mode=0777 "/mnt/NAS/Music" [20-Feb-2015 21:40:13 UTC] [20-Feb-2015 21:40:13 UTC] >>>>> cfgdb_update(cfg_source,dbh,,Array) >>>>> UPDATE cfg_source SET name='Music', type='cifs', address='', remotedir='music', username='gonace', password='***', charset='utf8', rsize='8048', wsize='8096', options='ro,dir_mode=0777,file_mode=0777', error='Usage: mount -V : print version mount -h : print this help mount : list mounted filesystems mount -l : idem, including volume labels So far the informational part. Next the mounting. The command is `mount [-t fstype] something somewhere'. Details found in /etc/fstab may be omitted. mount -a [-t|-O] ... : mount all stuff from /etc/fstab mount device : mount device at the known place mount directory : mount known device here mount -t type dev dir : ordinary mount command Note that one does not really mount a device, one mounts a filesystem (of the given type) found on the device. One can also mount an already visible directory tree elsewhere: mount --bind olddir newdir or move a subtree: mount --move olddir newdir One can change the type of mount containing the directory dir: mount --make-shared dir mount --make-slave dir mount --make-private dir mount --make-unbindable dir One can change the type of all the mounts in a mount subtree containing the directory dir: mount --make-rshared dir mount --make-rslave dir mount --make-rprivate dir mount --make-runbindable dir A device can be given by name, say /dev/hda1 or /dev/cdrom, or by label, using -L label or by uuid, using -U uuid . Other options: [-nfFrsvw] [-o options] [-p passwdfd].

Can’t seem to understand why!

I’ve tested every found “solution”, like reinstalling cifs, adding “sec=ntlmv2” to advanced “mount flag”, tried different user accounts and different shares on different computer, with no success!

Adding the network drive manually works like a charm.