Enable large amount of songs (60-k plus)

For people like me using a large amount of locally stored songs/titles (today approx. 100 k) Volumio “hangs”, “freezes” while browsing the “Musicdatabase”. Anything more than roughly 45-k local flacs, mp3, dsf is showing this behaviour on several individual installations; using a DLNA-Server as source is working just fine, but who wants to run a seperate DLNA-Server all the time?

PLEASE enable a large local Musicdatabase.

Setup: Raspberry 4b-2GB and lokal USB-5TB-drive

Volumio uses MPD for it’s database, and as far as I am aware there is no artificial limit on the number of songs that can be placed in it.

OK understood.
But something is going wrong. If it is not the database, it must be something else.
I have three different Pi´s (3b, 4b) and different USB-drives. I have re-flashed the sd-card(s) morge than several times (v2.779) and everytime the behaviour is “bad”.
After scanning the disk´´s and building the library, when i try to select “artists” the green progress bar (top of screen) is advancing to approx 98% and then “stucks” there. Sometimes the Pi responds again after a couple of minutes and than everything works fine until next reboot. In many situations volumio will not find any “artists”, “albums”, etc. any more.
I have always double-checked with a small USB-Stick (approx. just 50 songs). All installations with this small amount of files work well and very fast.

So, there seems to be an “issue” when Volumio is trying to handle large amounts of files, whatever the exact reason is.

Or perhaps there are problems with individual files with unusual/corrupted format?

That doesn’t particular help, but my point is that it may not be the large number of files.

Anyway, I have done some hours more of testing. The results are kind of surprising. The short answer is: Volumio seems to work with large amount of files.

Longer answer:
The key to “happiness” was to disable the automatic database-update on each “BOOT”.

  1. using a “clean” new installtion with “no” music-storage attached
  2. /etc/mpd.conf (parameter auto_update should be set to No)
  3. config.json file under /volumio/app/plugins/music_service/mpd. Parameter auto_update must be set to “false”
  4. reboot
  5. attach “large” music-storage
  6. using “ssh” and issuing “mpc --wait update” ==> takes about 2-3 hours until prompt returns
  7. works decently fine

From thereafter giving the Pi4 about 3-4 minutes of time after each “boot” and all further database updates triggered via “ssh”.

My explanation: the Pi4 needs a large amount of time after each reboot to update its database (unless update is disabled) and in this period of time it is extremly slow in “any reaction” to command. Probably one or another “boot” while the Pi4 was still updating its database (no “turning” on DB was visible in GUI) causes “strange” things concerning the database.

I will investigate further and maybe my experienced can help others.

To all of you: Have nice days and enjoy listening to music!