Don't get option to select wireless network

I am trying to get the latest version of Volumio setup in a place that doesn’t have Ethernet and so requires a WiFi connection. However using latest version (2.698) I am able to get the WiFi hotspot, but I am never able to get a select of WiFi networks to connect to.

I have tried the following Configurations:

  • Connecting to the HotSpot
  • Disabling the HotSpot and trying to choose locally with Keyboard and Mouse
  • Disabling the HotSpot and trying to choose via Web UI (Ethernet Connected on Test Bench)

I have tried with the following Hardware:
Raspberry Pi 2 with USB WiFi Adapter
Raspberry Pi 3 with built in WiFi
Raspberry Pi 3 with USB WiFi Adapter
X86 PC with Built In WiFi Adapter

All hardware was tested with other operating systems and finds and connects to WiFi just fine. All testing was done a few feet from the Access Point.

Every time I go though the Initial Setup and get to the Network Select, no WiFi network are listed. Is there anything that I can do to get WiFi selection to show networks or is there a way to download an older version of Volumio where the WiFi still works?