Distortion with Schiit Modi Multibit

I’ve had a Schiit Modi Multibit DAC for a while, and can’t get Volumio to drive it without distortion issues. I’m currently running the latest (2.185) on a Raspberry Pi 3. It mostly plays Spotify well, with a small amount of digital distortion every few seconds. But when I play ALAC music from my NAS every few seconds there’s some kind of drop out and digital noise.

Running piCorePlayer on the same hardware drives the Modi perfectly, so it’s not the hardware. Is there some setting I’m not aware of that can fix this, as I’d prefer to use Volumio over piCorePlayer.

BTW, for $249 the Schiit Modi Multibit sounds absolutely stunning!

Hi Jim:
1- Does this happens also with FLAC files?
2- Can you try to raise the buffer?
3- Try to remove dwc_otg.lpm_enable=0 dwc_otg.fiq_enable=1 dwc_otg.fiq_fsm_enable=1 dwc_otg.fiq_fsm_mask=0x3 from /boot/cmdline.txt
does it make a difference?

I think we may have a problem witht alac and aif files on newest MPD version

Hi Michaelangelo, I’m still having this problem after flashing the latest (2.245) release. I have 3 Pi’s, two with IQAudio DAC+, which work fine. So it’s not the type of music source. I raised the buffers to the max level, that didn’t help. When I removed the settings above from cmdline.txt all I got was hiss coming out of the DAC.

So there must be something stopping the combination of Volumio and this DAC from operating properly. It’s not the Pi hardware, as PiCorePlayer works fine with it. Any other suggestions? These Schiit DAC’s are becoming very popular, it would be great to nail this issue.

Was this release flashed from new? Does the resolution\bitrate matter?

Yes, it was flashed from a new download. I get a small amount of distortion at lower bitrates (e.g. Spotify), and a larger amount on ALAC CD Rips, and even larger on hi-res 96/24. This has been the case with all of the previous releases I experimented with.

It’s a digital kind of distortion sound with something that sounds like a click or set of clicks every few seconds, more frequent on higher res source material. I’m not sure what else to try, but at this point I’ve eliminated source material and hardware from the equation.

Do you have a USB powered hub to try? If yes, please do…
Let me know !

Hi Michaelangelo, unfortunately I don’t have a powered USB hub to try. I did a lot of googling on the subject, and it seems there’s been a long history of issues between Raspberry Pi’s and Schiit DACs.

I did try adding this to /boot/cmdline.text:


It solved the crackling problem and music played perfectly for about 2 - 3 minutes, then large audio gaps would occur. So still no solution here.