Display problem - Waveshare 480 x 800 HDMI


I am trying to display Volumio (v2.166) UI on a 480 x 800 HDMI display from Waveshare (https://www.waveshare.com/wiki/4inch_HDMI_LCD) connected to an Odroid C2.
I have been following all the tutorials here and on the Odroid forums but for some reason I am failing.
I’d like to highlight that I am able to use this display with Ubuntu on the Ordoid and can display Ubuntu boot and later on desktop.
I have been debugging a bit with what I understand so far (+ comparing the two systems) and it seems that for some reasons when I use dmesg in a ssh shell on Volumio, the resolution selected is always the 1920x1080 default one.

I am setting correctly the resolution in boot.ini, disabling the autodetection, enabling DVI and the file in c2-init.sh in /usr/local/bin seems executed.
I also tried to use the modeline command to pass my display timings, tried also to force in c2-init.sh a resolution for fbset or even pass to the frame buffer the timings in a shell using fbset -t xx xx xx xx…

But nothing works and I am a bit stuck here. I would gladly appreciate some help if possible.
I tried to figure out the most I can by myself as this is the best way to learn since I am a beginner here but I cannot see how to progress further, I must miss something but no idea where.

Thanks a lot for the persons who will take time to look at my problem,