Did I fry my relay attenuator clicking the mute button?

Hi. I installed the relay attenuator on a BOSS DAC 2 days ago on the newest version of volumio. Worked good, sounded good, and I’ve been adjusting the volume from the command line. But this morning I tried the volume controls on volumio/llocal screen. up and down ok, and then I did the mute button, which worked, but then wouldn’t unmute either from the screen or the command line. I uninstalled the plugin and reinstalled, no sound, either from the BOSS outputs or the RA outputs. So I did a clean install of volumio, and reinstalled the RA plugins. Nothing.

sudo apt-cache policy lirc to check if packages are installed, yes

sudo r_attenu -d to run the daemon in the background responds

r_attenu: could not connect to socket
r_attenu: No such file or directory
failed to initialize lirc

I do however now get sound from the BOSS outputs.

Any clues? Thanks

I don’t think you can break anything on relay attenuator from software side, if it was not already faulty. It is very simple device - just two I2C to parallel port extenders - one to control relays switching resistors and another to scan button inputs. There are bunch of problems with volume control in last volumio, I suggest to make clean image on other sd-card (preferably older version before problems with volume control) install plugin fresh and test if it works. If not there might be really some defective hardware.

OK, Thanks Charly. I went back to the October version, and reinstalled and back to working. I had tried reflashing and installing the new version again, but that didn’t work. Again, Thanks.

I seem to have a similar problem with my Attenuator.
Whenever I mute I cant unmute afterwards, reboot doesnt help.
At least I found a procedure to get my player working again:

  • disable Attenuator plugin
  • mute Volumio
  • unmute Volumio
  • enable Attenuator plugin