Dell Wyse Cx0 x86 does not boot

Hello, I greet you all.
I wanted to install the volumio x86 on the Dell Wyse Cx0.
I see the login when booting, then 3 white squares and then the screen stays black.
It is a VIA Eden 1GHz, i686, chipset VX855, 2GB Ram, 4GB USB stick. Is it because it’s just a 32Bit CPU? Or is the graphics card not recognized?
I want to get the thing up and running, with touch display, since it consumes only 7 watts.

Can you access the Volumio UI from a browser on another device? Just wondering if the boot is actually failing, or just that the graphics driver is causing a problem.

Now I have the latest version 2.502 installed. When booting I see the graphic “Volumio”, then console with login and then black screen. However, I now have full web access and I can play music. The web interface is very fast here. Great! But actually I wanted a screen display with touch control. What conditions must be met to output a picture via DVI or VGA?

Have you looked at the touch display plugin from the plugin page?

I can not find the touch display plugin. Plugin Accessories is empty. Can it be that something went wrong with the image build? I also miss the autoplay plugin.

First things first, which touch screen?
Brand? Model?

No, nothing wrong from your side - it is because i386/plugins.json doesn’t list these plugins.

x86 does not need a plugin, starting in kiosk mode is generic as most x86 devices have a monitor of some sort.
@Harnisch: have you tried with a normal DVI monitor connected?

I have tested it with a Samsung 204b via DVI. Also I tested the FT700TVGA touch display 800x480 via DVI-VGA adapter. Both will take the picture if the web interface is available. Screen reports “no signal”.
I do not understand why all the plugins are missing.

I have missed something here probably, did you mean the web interface is not always working?

Should be OK

I must admit, me neither, but I can guess a good reason for it.
Most plugins have been developed for or using the arm-based RPi (or other sbc), possibly relying on backend software components which will not run on an X86 platform anyway.
I reckon there is some work to be done here and leave the answer to the Plugin developers, I’m not into node.js programming, sorry.

I mean the web interface is reliable, only the connected monitors does not show anything.

Ah, I missed that, sorry for the noise!

This is true for plugins that need platform specific binaries (volspotconnect2/spop)/node_modules (native modules - such as onoff - which would be quite pointless given that x86 with gpio access is quite rare!) but in other cases it is because it didn’t get included in platform specific plugins.json the plugin manager uses.

Autostart should just work™ with x86 as well :slight_smile:

I can not get any further here. It would be nice if a developer cares that the important plugins are also made available for x86. Startup does not work. When the power button is pressed, I want the last station to start playing again. And I want to be able to change my channels via the touch display. For this I need a screen output. Maybe the chipset is not yet supported and would need to be added?

I guess you are right with unrecognized graphics, thin clients are a bit exotic and we do not claim to support all devices out there.
You could try one of the dev images in the hope of better hw support, I did select more drivers than in previous Debian kernel. There is nothing else I can do, sorry about that.
See the opening post in Volumio Developments/ Development talks/ Next x86.

I tried to find boot/config.txt to manually add my resolution or fix bugs. Are not there in x86? I found only the config3.18.25.
There are different processors disabled, why?

config_MVIAC7 is not set

I would be very grateful to you if you could take a look at it and take the Dell WYSE Cx0 with it. I have started the current Debian Live CD and there is also a picture on DVI!
For me, this is the ideal machine. Only 7Watt, fast web interface, 32bit 192kHz HDSound, available for 10 €, very nice case. I do not think that is uninteresting for others.
There are also Ubuntu 12.04 graphics drivers for the VX855 chipset, it should be possible. Even though he is older, I do not need an i3 to play music. … Select.jsp

You could try a dev version from Volumio Development/ Development Talks/ Next x86.
I appreciate you testing a number of “oldish” thin clients, but we can’t afford time to support due to lack of demand.

Thanks to Thomas Doerr, who wrote the startup plugin for x86. You are the hero of the month, thank you.

The Development Talk says: “There is nothing new in it for people with older hardware (>3-4 years) as we are not adding Volumio functionality.”
For me that means little hope that something will change, because no one wants to support the older thin client. I think that’s a pity. You should think about who your target audience is. That’s next to Rasperry Pi, just the thin clients. Not only the new, expensive, but also the older cheap. And when I see an Ebay seller selling over 1500 pieces of Futro S900, they are available in large quantities. Probably the Dell too. And it will not be long before the Futro S920 is affordable. So there is always replenishment with newer “older” hardware.
Before you hear a good-sounding sound at the Rasperry Pi, I have to pay around 100 €. And you need housing then … That’s why I choose the Dell.
I could only help you to test new images on my thin clients.

I’m not saying it is impossible, we just don’t have the time to support all possible configurations out there.
For the X86 I used Debian’s kernel 3.18 and the then available drivers and firmware.
When that does not suport the Dell Wyse, than we’re out of luck.
Perhaps there are drivers, but adding out-of-tree drivers to kernel 3.18.25 is not something we want to do, not for the current kernels either, I’m sorry.
In case the Wyse graphics does not work because of missing firmware we had that with some nvidia vards too), you could still try the de image (small chance though, but it has a larger set of firmware modules).

Otherwise, why not use them headless, you would still have a bargain?

I’m looking forward to the new image with the new kernel, maybe it’s still going on. Until then, I will use the Wyse as a headless, add Wi-Fi USB stick and runs great.

Well, that has been solved: