Dark screen (Hdmi) after installing Touch display


First, i’m sorry for my pretty bad english, i’m french…

I’ve installed volumio on rpi 3 b+ by following step by step the quick start guide.
I have no problem to using volumio by my browser. But i would like to use it with a screen connected by the hdmi port of my rpi.

I’ve installed the touch display plugin. When it’s activated, my screen (hdmi) go dark, i still have a signal but it’s all dark.
As soon as i disable the plugin, there is on my screen :
"Raspbian GNU/Linux 10 volumio tty1

Welcome to Volumio!
WebUI available at volumio.local (ip address)
volumio login : "

Maybe i’m dumb, but i really don’t know what to do to use Volumio with a screen connected to my hdmi port.

Please help me.

Respectfully, yog68

Please add some information:

What is your Volumio version?

What is the brand and model name of your display?

Hi gvolt,

i have tried two versions of volumio, one with the raspberry pi imager and one directly from the site volumio (v 3.198). Both with the same results.

Concerning the display, i tried with two different screens. My samsung TV an old plasma display (55") and with my PC screen (ASUS 27" LED - ROG Swift PG279Q). Each time, same results.


So, I assume you are using Volumio 3.198. (?)

Please connect to Volumio via SSH and post the output of

ls -al /usr/share/X11/xorg.conf.d

Yes, i’m using Volumio 3.198.


Now run

sudo curl -L https://raw.githubusercontent.com/goodtft/LCD-show/master/usr/99-fbturbo.conf-HDMI -o /usr/share/X11/xorg.conf.d/99-fbturbo.conf

sudo sed 's/"fbturbo"/"fbdev"/' -i /usr/share/X11/xorg.conf.d/99-fbturbo.conf

and reboot.

I have followed your instructions. Nothing have changed…

I’ve tried to post again :ls -al /usr/share/X11/xorg.conf.d

the file 99-fbturbo.conf is there…

I’m glad for your help!

Which display are you currently using?

Has the display been connected during the reboot?

Please post the result of

cat /var/log/Xorg.0.log

If you should have modified “/boot/config.txt” or “/boot/userconfig.txt” post their content using

cat /boot/config.txt
cat /boot/userconfig.txt

If possible, don’t post screenshots. They are not text searchable and on mobile devices it is hard to look for information in them.

Just copy the text from the terminal, paste it into your post and format the pasted text using the “</>” symbol or Ctrl+E.

Ok i will do that tomorrow. I have to go to work for 30h straight and i won’t be able to update you during that time.

However, i’ve encountered a new problem, i can’t connect to volumio by putty anymore… I still can login via my hdmi display. I’ve tried cat /var/log/Xorg.0.log and a fatal server error has been detected : [42.369] (EE) no screens founds (EE).

I think, i’ve done something wrong so, when i come back tomorrow, i tried a new installation of volumio, follow from the top all your instructions and get back to you for the results…

Lots of thanx for your quick answers.

Hope i’m understandable :slight_smile:

Take your time. :slight_smile:

In case you should decide to install Volumio from scratch enable “Plugins Test Mode” on //volumio.local/dev and install 3.3.5beta of the Touch Display plugin. Unlike 3.3.1, this version detects download errors and cancels the installation of the plugin. Also at first check if the screen is working without running the commands from post #6.

Hi gvolt, so i’ve solved my problem. I don’t really how but it’s done. I’ve installed volumio on a new microSD card, install the touch display plugin and worked… I think there was a IP address “conflict” between two of my raspberry… Don’t know if it was linked but it’s working :slight_smile:

Thanks a lot for all your help !

1 Like