Dacs (Schitt Modi 3 or Khadas Tone 2) not showing up

Volumio Information

Volumio Version: Latest
Hardware: Pi4
DAC: Schitt Modi 3 and Khadas Tone 2

I am having trouble with volumio not seeing the Schitt Modi 3 or the Khadas Tone 2 for Outputs. I can plug in the Topping D90 and it registers right away? Is there something special that has to be done for the Modi3 or Tone2 to show up as output devices when plugged in over USB?

Hi gguertin, welcome to Volumio. :slight_smile:

Nothing extra should need doing other than perhaps a reboot with the DAC connected, but we could do with seeing what Alsa is/isn’t detecting;

would you share the system log please?

1 Like

just adding to @chsims1 correct request.
This is what I get with a Khadas Tone 2 Pro, using version 2.882:

volumio@rpi:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
  Subdevices: 3/3
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
card 5: Pro [Tone2 Pro], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

volumio@rpi:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 3353:a002  
Bus 001 Device 002: ID 2109:3431  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

ID 3353:a002 is a Khadas Tone2 Pro, which shows this when doing dmesg:

[  141.438009] usb 1-1.2: new high-speed USB device number 5 using xhci_hcd
[  141.568596] usb 1-1.2: New USB device found, idVendor=3353, idProduct=a002, bcdDevice= 1.00
[  141.568602] usb 1-1.2: New USB device strings: Mfr=1, Product=3, SerialNumber=2
[  141.568607] usb 1-1.2: Product: Tone2 Pro
[  141.568612] usb 1-1.2: Manufacturer: Khadas
[  141.568617] usb 1-1.2: SerialNumber: 0CA20007
[  141.694282] usb 1-1.2: 1:3 : unsupported format bits 0x100000000
[  141.697636] hid-generic 0003:3353:A002.0003: hiddev96,hidraw0: USB HID v1.10 Device [Khadas Tone2 Pro] on usb-0000:01:00.0-1.2/input4
[  141.699200] input: Khadas Tone2 Pro as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.2/1-1.2:1.5/0003:3353:A002.0004/input/input1
[  141.768162] hid-generic 0003:3353:A002.0004: input,hidraw1: USB HID v1.10 Device [Khadas Tone2 Pro] on usb-0000:01:00.0-1.2/input5

So in principle, PI 4 with version 2.882 works with Khadas Tone 2 Pro (can’t verify a Schitt Mode 3, don’t have one)

@gguertin please always mention the exact version number, saying “latest” is of no use as in 1 day or 2 weeks later this info will already be misleading :see_no_evil:
Looking forward to the log.

find here the same problem no solution

Please do not add links to 4 year old posts, which refer to different PI Volumio versions with completely different kernel versions, not helpful at all.

the one you linked is from 2017

Just to follow up on this I changed the cables I was using for both? 1 was usb mini and another was usb c and after a combination of restarts I am getting both to work… It seems like after its been found once it finds it again right away with a restart. I did set it to microphone each time I wanted to switch and then restart not sure if that made a difference.

I didnt see the post update before I switched cables or I should have run the command requested to see what was being seen but its possible it was cable related.

that is possible because your dac is uac2 and should be ok…
some of the dac’s needs a reboot to work.

Glad you’re sorted, please mark the post as solved (you can select the “solution” in
the bottom options of the appropriate post).