.cue files appear twice in "Music Library" and crash volumio if parent folder is enqueued for playback


Volumio Information

Volumio Version: 3.631
Hardware: Raspberry Pi 4
DAC: PS Audio NuWave DSD

Debug Log

The link to the log capturing guide is old and no longer works.

Steps to Reproduce

  1. Have a .cue file in a folder on a source of some kind (I tested CIFS and USB, both exhibit the issue)
  2. Navigate to the folder via the Music Library
  3. You will see the folder appears to contain the .cue file, plus any track defined within the .cue, plus the .cue file again. Either listing of the .cue file will play normally. In reality only one .cue file exists.
  4. Navigate back out of the folder
  5. Click on the three dot menu to the right of the folder, and click “Clear and play”
  6. Volumio crashes and reboots

Additional Information

This started after updating to the latest version from 3.396, however a fresh flash presents the same issue.


From watching journalctl in real time, I can tell you the part where it says FATAL ERROR with all the exclamation points appeared right after I triggered the bug.

please try to enable test mode and update to the latest beta version, some problems with .cur files have been solved.

The same thing happens.
I saw in the changelog that something was fixed with wrongly formatted .cue files. The issue I am encountering isn’t limited to only some files, it’s been each and every one I tried so far, so long as I play the folder. If I play the file directly, it works.
In the logs at the time of crashing, I am seeing something about attempting to resolve the same promise twice with kew.js. At a wild guess, I’d wager the duplicate entries and the crash are related.