Crack - Spotify & Pifi Digi+

I have a setup:

  • Volumio (2.310)
  • Spotify (up to date plugin)
  • RPi 3
  • Pifi Digi+
  • Rotel RA-12 (via SPDIF)

There’s a problem with songs with different resolutions (16bit vs. 24 bit). If you have songs with different resolutions in the queue, you can hear audible “click” (crack/ snap) from the amp when a song with resolution different from the previous one starts. The solution was pretty simple - switch on the re-sampling feature so the amp is fed with the constant resolution and have no reason to “re-clock”

However, this is not possible with Spotify which is not using MPD and streams directly do the Digi+ board. There’s a click every time a new songs starts or I manually seek in that songs.

At the time of seeking, the spop’s log contains:

2017-11-12 18:14:18 [DBG ] [ice:18] Received command: seek 83000
2017-11-12 18:14:18 [DBG ] Command: [seek] with 1 parameter(s)
2017-11-12 18:14:18 [DBG ] SoX: requesting player thread to stop.
2017-11-12 18:14:18 [DBG ] [ice:19] Received command: idle
2017-11-12 18:14:18 [DBG ] Command: [idle] with 0 parameter(s)
2017-11-12 18:14:18 [DBG ] SoX: player thread stopped.
2017-11-12 18:14:19 [DBG ] SoX: starting playback...
2017-11-12 18:14:19 [DBG ] Opening SoX output (type: alsa, name: plughw:1,0)...
2017-11-12 18:14:19 [DBG ] SoX: adding effect: spop_input
2017-11-12 18:14:19 [DBG ] SoX: adding effect: gain
2017-11-12 18:14:19 [DBG ] SoX: adding effect: treble
2017-11-12 18:14:19 [DBG ] SoX: adding effect: rate
2017-11-12 18:14:19 [DBG ] libsox: rate: has no effect in this configuration
2017-11-12 18:14:19 [DBG ] SoX: adding effect: spop_output
2017-11-12 18:14:19 [DBG ] SoX: adding effect: output
2017-11-12 18:14:19 [DBG ] SoX: player thread started.
2017-11-12 18:14:19 [DBG ] sox stats: samples: 0; stutter: 1

At the time of seek (or start of a new song), SoX closes and reopens the output (ALSA at this log but I’ve tested ao with the same result) which forces Rotel to sync again.

Have anybody experienced this issue? I’ve borrowed Behringer UCA202 (USB transport - connected via SPDIF as well) from friend of mine and it worked without this kind of problem.
I’m still not sure whether it a problem of the Chinese clone of Hifiberry Digi+ or I am missing something in a configuration file.