Could not load/find Alsa

So now I got most my car audio project working, but somehow the Hi-Fi berry DAC 2 stopped working. On bootup the green light on it would light every time. I read if you disable restart and re-enable it will work, but that didn’t fix it. It’s very picky in which DAC option I choose in app, so I pick the first hi-fi DAC on the list, and it was fine. I tried searching my problem but a lot of DAC threads didn’t seem to have an answer. I will try plugging it back inside the house, because it might be a power issue.

I’m running Volumio 3.179 with Raspberry Pi 2B

*Update - Tried powering on the Pi in the house, and the DAC still won’t power on. Tried turning off I2S or what’s it called and reboot, then turned it on, still no power, is there a script I need? I normally just select Hifi berry DAC (first hifi option) and it turns on.

Did a little voltmeter work and tried to see any spikes or drops on pin 2 and 4 grounded to pin 6. they stayed 5v during the whole boot. However, I noticed now as I load a DAC profile it will turn on, but only up to the Volumio chime, after that it shuts off. Also, I can choose just DAC, DAC plus, or DAC + Pro so far they all power the DAC on. Any idea which one I’m supposed to use?

  • I also checked the EEPROM setting in the config.txt and it was already coded properly.

did you try this :
look at the last post :wink:

I haven’t tried that. Where would I get V2 at? Also I used " Aplay -L" and it show’s:

Does this mean if it’s visible, then Volumio recognizes it?

v2 isn’t supported any more so …
yes it shows there but does it show in volumio?
if you comment it out the part force_eeprom_read=0 it should be there.
but i think you will still have a asla problem.
i think you could get the latest version of v2 still some where i will look 4 you.

Well, as long as I’m connected over hotspot I see my profile, but I’m not sure what you mean by seeing the DAC in volumio, I see lots of hifi DAC’s to load. Oh I’m supposed to remove the EEPROM line? I saw it in there and thought I was supposed to leave it. Lemme go change that. Ok thanks!

not remove it just comment it out so that it won’t load for test.
this is a guess so try it maybe it will help…
your dac should be this one “DAC plus”

Ok I just commented it with “#” and still it turns off after the chime. Ya DAC plus was what I used starting out.

uhm i’m still looking in posts to find any help … i think you can take the comment oway.
all i can find is or switch back to v2 or use HifiberryOS.

Ok, If I have to buy a different DAC that’s ok, but then…at that point I may have to upgrade my Pi anyway, I just don’t know how I had it all working before. Unless it was never really stable? because I only played music from it for about a day probably.

i have a pi 4 /4gb and a khadas tone board on usb …
but at the moment it is hard to get your parts.