Connection with iomega NAS ix2-200

Dear all,
I’m a fresh user of Volumio (on RPI 4) and all together very satisfied.
Configuration at this stage: RPI 4 via Wifi, music on USB stick, usb link to Chord Mojo DAC, tube amp, diy speakers.
I managed this way to test some high res files playback and it sounds already very nice!

What I fail to manage is to connect with my good old iomega NAS. I tried several things found on forums like this but nothing worked.
I always get an yellow/orange rectangle stating via an uncomprehensive message that it doesn’t work…

My NAS has been enabled to support NFS and CIFS, and I have full access via my windows 10 PC.
At the moment no passwords or other safety is enabled (I think…)

I’m really out of ideas how to solve (I’m do not know linux commands etc to dig in deeper). I’m unsure if it is my NAS or Volumio config.

Have you tried to set “vers=1.0” in advanced options?

yes I have
vers=1.0 or =2.0 or =3.0 I all tried

last try:

Alias: NAS
NAS IP adres:
Path: media\music
File Share path: nfs
Options: vers=1.0

after click on ‘save’ I immediately get error message:
Error in adding network drive
exec error Error: Command failed: /usr/bin/sudo /bin/mount -t nfs -o ro,soft,noauto,‘vers=1.0’ ‘\Music’ ‘/mnt/NAS/NAS’

“vers=” only relates to cifs /smb versions, do not use it for nfs as this would result in an unknown mount parameter.

Could you send us a log please, see
Post the URL you get here, or/and send it with your forum nick to volumio(at)

more questions :wink:
did you select from the scanned hosts and their libraries?
And could you give us a little more info on how your Iomega is configured?

pls find here the report

Further on:
config IOMEGA
I think he is set-up as simple as can be.
No security paswords nor user mgt or quota are active.
Disks are mirrored (2x500GB)
I will sent you by mail some more screenshots
Disabled are: AFP, FTP, TFTP, SNMP
Enabled are: NFS, CIFS : directory mode = Workgroup (and not active directory domain) and Workgroup name = WORKGROUP
Network setting : on all automaticly configure all network settings


When you mount using cifs, you need to add vers=1.0 to the advanced options, according to the log file you did not. Only for nfs, “vers=” is not a valid option.
I have not seen anything odd when mounting nfs, could it be that you did not set correct permissions (e.g. by remapping all access to root (or admin)?

I think that mybe de path are not correct.
I was have the same problem.
I was write path "Music " dirctli, and the same message appears.
At the finish, a little detail was the solution.
The correct path are \Volume1\Music

Is only a suggestion