Configure Volumio WiFi on Pi without using cabled Ethernet

Connect monitor and keyboard…

sudo nano /etc/network/interfaces
Add the following lines using your own WiFi SSID and PSK PASSWORD

allow-hotplug wlan0 auto wlan0 iface wlan0 inet dhcp wpa-ssid SSID wpa-psk PASSWORD

To speed up boot and disable the cabled Ethernet delete these lines from /etc/network/interfaces

auto eth0 iface eth0 inet dhcp


Disabling Ethernet like you just did shouldn’t be a problem perse but if you change anything your network configuration, like change passwords or the name of your wifi, you would need access to Volumio.
You could do this via the serial interface but that would be quite a pain and costs you even more. (the cheap usb/ttl adapters don’t have windows 7+ drivers since there knockoff and Microsoft had an driver update a few years ago). Or connect to a screen and keyboard but wheres the fun in that.

So I would not completely disable it, but set a static address outside of your normally used IP range and make sure you remember it. Saves you some trouble/re-imaging/re-installing.

Hi MobeyDuck

Good point and sound advice.

My only misgivings are if you already have a port and cable then you don’t really need this guide in the first place. But if someone gets Volumio working on the Pi Zero…

I just installed Volumio 1.55 on my raspberry Pi 3 which has wifi. I do not have the Pi connected to via ethernet as I would like to use Wifi.
When I boot up Pi / Volumio it seems ok until the very end of the process. Toward the end of the process, I get a message: Fail start par: service(s) returned failure: transient log.

As this is a first-time project for me. I am wondering if the failed message is related to no wifi being configured or is this type of message indicative of some other issues?

Thanks for any suggestions

1 Like

This message, as far as I know, is nothing to worry about … I get it too. I vaguely remember reading somewhere in the forums that it was a legacy result of the boot image.

1 Like

I had volumio 2 installed on pi 3 but after following the steps I am not able to connect to my house wifi. Anything I need to do for trouble shooting

1 Like

Does it connect to the WiFi if the ethernet port is plugged in? I’ve ran into a similar situation and eventually decided to strip the eth0 stuff out of interfaces as indicated in this topic.

The wifi is not connected even with the ethernet port plug in. Using wired connection is all good

I’ve been trying to get WIFI to work on my PINE64+WIFI module build but no go.

Even after editing the config file

sudo nano /etc/network/devices

auto lo
iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp
allow-hotplug wlan0
wpa-ap-scan 1
wpa-scan-ssid 1
wpa-ssid “Network name”
wpa-psk “Network password”

It’s just not connecting to my network.

Does anybody have any success with this setup?

1 Like

Pine wifi is still a Work In progress

Thank you for the update. I’ll keep an eye on the new releases as I continue to learn Linux commands.

hey i’m newbie,
i have volumio 2 on raspi pi3 connected to a dac marantz na8005. after many troubles it works good. but remains a problem with wifi. i Follow the steps indicated, but an ifconfig shows always and i need always to Force another IP

The substance of this thread is a long time out of date. Don’t alter /etc/network/devices. is the IP address of the volumio hotspot. Connect to this initially, if necessary, but then disable and setup your own wifi network through the Volumio UI

I did this and can see many networks from my neighbours and yet cannot see my own home networks. BTW it works fine on Lan but not on wi-fi!? Any clues?

Thanks from a newbie. :question:

1 Like

Firstly some details … what is your device, Volumio version, & wifi adapter? Is the installation a fresh flash or an update of an earlier version? Can you see your home wifi on your phone?


Sorry about that. I have a Netgear r7000 router which broadcasts on 2g and 5g which is visible on all devices. I have set permissions for the Lan but the WiFi just does not show up to log into. I have also set permissions for all new stuff to be able to hook up without passwords (temporarily) and still no go. Weird!!! This on 3 raspberry pi 3 b with usb out or with hifiberry DAC plus gpio card. Also used updated as well as original 2.141, 2.163, 2.175 and 2.185 versions. Hope that is enough - please let me know if not.



Btw also tried​ hotspot with and I can see the raspberry s but I still can’t find my networks even that way.

Is it because your router is not broadcasting the ssid address? If so, you should be able to manually add your wifi name & details.

The router is broadcasting the ssid
I also tried to manually add and still no go. Very confusing :confused:

1 Like

I’m still not clear on your setup here, bear with me while I try to get things straight …

presumably mobiles, tablets etc??

You are running 3 RPi3s …do any of them see your network? Are they all using the internal wifi? What OS is running on each of them?

What exactly do you mean by “can see the raspberry s”?

Weird one this one as I can now see my router and I have not changed any settings on it. I’m confused but at least seems to now be working. :question: I think it might be something to do with amount of items to discover as per my other thread.