compiling wifi driver (rt5370) unknown symbols

Hi there,

I am trying to use my raspberry pi with volumio and wifi-stick with an Ralilink RT5370 chipset.
The Stick is working is working plugnplay with volumio and raspbian. But the performance is really bad, it drops the connection very often and has only limited speed. This is because of a bad driver.

Under Raspbian I could successfully compile and load the the provided driver from the manufacturers webpage. The performance was like a 100x better. … 2-usb-usb/
So now I tried the same with volumio, following the guide from michelangelo in this thread:

The Module.symvers was missing, so i grabbed one from the raspbian github source.
After that the “make” and “make install” of the driver worked. But sadly I am not able to load the module with modprobe.
Here is the ouptut:

root@volumio:~# modprobe rt5370sta
ERROR: could not insert 'rt5370sta': Unknown symbol in module, or unknown parameter (see dmesg)

[  878.326091] rt5370sta: Unknown symbol __udelay (err 0)
[  878.338347] rt5370sta: Unknown symbol dev_get_drvdata (err 0)
[  878.351361] rt5370sta: Unknown symbol __bug (err 0)
[  878.363026] rt5370sta: Unknown symbol local_bh_enable (err 0)
[  878.375860] rt5370sta: Unknown symbol local_bh_disable (err 0)
[  878.388143] rt5370sta: Unknown symbol dev_kfree_skb_any (err 0)
[  878.400563] rt5370sta: Unknown symbol dev_alloc_skb (err 0)
[  878.412634] rt5370sta: Unknown symbol __const_udelay (err 0)
[  878.424789] rt5370sta: Unknown symbol dev_set_drvdata (err 0)

Can anyone guess why this is happening? I also tried to use rpi-source for ther kernel source and some older driver versions. But all of them give exactly these errors. So I think it has something to do with volumio itself.
Thanks in advance!