[Closed] Volumio 2 Beta versions for Odroid

As of now, beta images for the following Odroid devices will also be available:
Odroid C0/ C1/ C1+
Odroid C2
Odroid XU4

You will find them at my odroid repo
The official Volumio repo will also have these beta images as from sometime the coming week.

gkkpch thank you very much :wink: ,i try the C1+ image this week end,the DLNA is established? i will soon replace my C1+ by a C2.

PS. C1 and C1+ image are the same compatibility? in repo all the image are C1.

look again carefully :slight_smile:
There will always be 2 images for the C1, the current and the previous version.
Both will cover C0/C1/C1+, if necessary a small change can be introduced to disable HiFi DAC for the C1 (remove the two lines from /etc/modules).

Note: currently the repo is only for the beta period and acts as a backup.
It might become a repo for unofficial/ patched images before they will be covered (or not) by the volumio updater (like a long planned standalone with Odroid-VU).

Hopefully this week we can add the odroid images to the volumio updater.

Yeap,good :wink: .The DLNA feature is implanted?
Best gkkpch.

Many thanks. It’s working well on my C1+ and Hugo DAC. Will do a full test against my Pi2/Hugo/Linear PSU setup over Easter and report back.


Testing with my C1 but a lots of hiccup with HD flac 96kHz and above. (In the mean time, my hardware combo C1 with several DAC work normally with Rune).
Edit will test 20160326 and report soon.

what DAC are you having these issues with, the HiFi shield or something else?

I re-checked and it seems an usb audio patch has gone lost.
Without it, there are issues with some USB audio DACs like you described, it can even crash a C1.

Could you please try the following as the last line in /etc/modprobe.d/alsa-base.conf and report back?

options snd-usb-audio nrpacks=1


I added a version for the Odroid X2 to show the feasibility for older Exynos4412 based devices like the U2 and U3.
The 4.4.6 kernel for the X2 is based on odroid community work, excellent for a headless Volumio 2 install.

I’m a long-time user of 1.55 and was curious about V2 so I tried testing RC1 with Odroid c2 and hifi-shield but don’t succeed:

Startup seems normal according to the red and blue LEDs, the blue one does the heartbeat after a few seconds, but i don’t get screen output and can’t reach the webinterface.
The Odroid, the SD-Cards, the Card-Reader(s) and the Workflow of Flashing should be ok, as all is working with other images (Odrobian, Ubuntu).

Any ideas, what might go wrong?

Thanks for your effort!


Sofar no one else has reported this behaviour, but it does look at bit familiar from what I experienced sporadically while testing the build procedure.
Could you try powering off and on again? You might have to try that a few times with leaving some time in between.
It seems, sometimes the C2 cannot locate the 2nd partion on the SD card, sofar they (Hardkernel) were not able to confirm the issue.
It gets stuck in the init routine, so booting already started hence the leds are ok.
If you can confirm, that sometimes it works and sometimes it doesn’t, then that would be of great value.
Then it might be the way our boot procedure works, I will have a closer look at it this weekend.

Edit I now have an improved test version and will upload it tomorrow night


I tried 3 different cards which all verified successfully with the Odroid-Imager, each of them with 3-4 restarts:
no change

I’ll try the upcoming new version and report back!

As an Odroid user I am familiar with dear raha’s issue.

The solution is to use an Odroid compatible image that can be found in gkkpch’s rep (he had given me the link to access. Browse through my last posts)

That was my only way to use v2 in my C1+

Ps: just found out the link: oph.mdrjr.net/gkkpch/

Sent from my iPhone using Tapatalk

Hi Mair: that’s the link in the OP, i’m using these versions

I just tested the new …RC1-fix… files: no change, same behaviour.
The monitor is recognizing, that there is a signal - it awakes from standby, but stays blank, no further startup-info …



i seem to be a step further:
I noticed, i can reach the odroid via putty, shortly after bootup!
Still no webinterface and no monitor output though.

Also there is some reaction in the mobile app MPD-Remote:
it connects, i can “select outputs” (“alsa” or “multiroom”), Volume is -1%

Here’s the output from SUDO BLKID, as you mentioned problems with the second partition:
volumio@volumio:~$ sudo blkid
/dev/loop0: TYPE=“squashfs”
/dev/mmcblk0: PTUUID=“5b250000” PTTYPE=“dos”
/dev/mmcblk0p1: SEC_TYPE=“msdos” LABEL=“BOOT” UUID=“3BF0-A9F4” TYPE=“vfat” PARTUUID=“5b250000-01”
/dev/mmcblk0p2: LABEL=“volumio” UUID=“5a48f24c-1593-492f-afae-1204d1130abf” TYPE=“ext4” PARTUUID=“5b250000-02”
/dev/mmcblk0p3: LABEL=“volumio_data” UUID=“76fe7e7c-a347-41b1-8359-c2f912e0642b” TYPE=“ext4” PARTUUID=“5b250000-03”

Attached is the output of dmesg directly after bootup.

I would like to help to track this issue down, if you do want to guide me through the process, as I have just some basic linux knowledge…
dmesg.7z (11.9 KB)

Guys, I will replace the RC1-fix for the C1/C1+ and C2 shortly, to make sure we have the same version.
There was a problem with the C2 during boot, sometimes it would fail to detect /dev/mmcblk0p2

Edit This can take a while, building Volumio images is broken at the moment.
That problem must have slipped in after I tested the RC1-fix before preparing the Odroid images for the repo.
I’ll contact Michelangelo.

The current C2 version is completely headless, no hdmi output yet.
I will look into that later.
In case you order other parts from Hardkernel or one of their distributors: order an UART interface with it, especially when you like to experiment with other distros, kernels etc. It hardly costs anything, but it is very, very helpful for boot monitoring. I would not want to miss it anymore.
(Probably the reason, why I have not had the need yet to add console output :mrgreen: )

oh, that’s some reasonable explanation for my problem :wink:

i’ll test any new builds and report back!

Ok, in about 10-15 minutes you will find a RC1-fix for the C2 with the link mentioned above, please try it.
Edit http://oph.mdrjr.net/gkkpch/
The occasional hang while booting should be solved, welcome to report any other error.
I can only fix C1 or C2 build related issues on this one, no new/improved functionality as we are in the middle of preparing for the next Volumio 2 version.

Note: this version needs a restart after selecting the DAC, otherwise you’ll just hear a plop and some noise when playing music :astonished:
I will sort that problem with the developers, it is a configuration issue.

I’m testing the new version now and finally got the webinterface and some sound! Great work!

First impression:
The webinterface is blazing fast, compared to V1.55 on RaspberryB - woohoo!
Sound is great!

Volume control is not working in Webinterface and App
Jumping inside tracks (the left circle on Frontpage) is not working in the Webinterface but works in the App
Access to network drive (password-protected SMB-Share) is lost after reboot

Will keep reporting…

Correct, the hifi dac does not have volume control and currently there is no switch to software control

Ok, need to look into that

Encountering this too, noted
Edit: as a bypass, re-enter user and password under advanced options and press “Save”

Could you do some reboots and confirm it consistently starts Volumio?