Clicks and pops during playback

Hi, using Volumio 2.917, I keep getting pops when playing music. Either streaming direct from my NAS (Flac 44khz/16-bit), or when streaming from Spotify (through Spotify Connect plugin). The pops are very frequent, but at random intervals.

I have an external DAC (Motu M4) connected through USB on a Rpi4 (already tried different USB ports, either USB 3 or USB 2 and no change in results). Software mixer is disabled, all volume is controlled on the DAC itself. I also have a small OLED screen installed, using the MPD OLED plugin, and I know sound gets routed through something first so the OLED can display a spectrum of the current playback. With Spotify it can’t route the audio through anything, but I still get pops when playing music through Spotify (so I don’t think MPD OLED is causing it).

Any ideas that can help me troubleshoot how to fix this?

  • Disable all plugins and retest
  • You have SW Mixer disabled, it’s now set to none?
  • What setting do you use for DSD Playback Mode?

Ok, I disabled MPD_OLED, and I still get pops. Then disabled Spotify Connect and GPIO Buttons plugin, and still pops.

SW Mixer is “None”. So volume in Volumio is locked to 100%.

Playback mode options:

DSD Playback Mode: Direct
DSD Auto Volume: Off
Volume Normalization: Off
Audio Buffer Size: 2MB
Buffer Before Play: 10%
Persistent Queue: On
Playback Mode: On

I changed buffer size to 12MB and Buffer Before Play to 40%, and I still get pops.

Your clicks and pops are within a track, or at the change/beginning of a track?
Is your DAC performing any resampling?

Within the track, not at change/start of track (that’s clean).

My DAC shouldn’t be doing any resampling as far as I know. It will just play the sample rate from the source file. It’s a DAC I use all the time with my Win10 PC without issues, FWIW.

1 Like

Not sure if this DAC is fully supported under linux as I see mention of drivers for both MAC as Windows. maybe the folks from Volumio can provide support here.
You run it on a rPi4?

On a Rpi4, yes.

1 Like

Which version and connected to USB3?
run command “pinout” from shell.

Hmmm, I get command not found when I type “pinout” when connected to SSH. I’ve been having that with a few commands actually. Does something need to be added to path here?

Running a Rpi 4 Model B with 4GB RAM. DAC is connected to USB 2, as it’s technically a USB 2 device. But I got pops on USB 3 as well.

I just tried enabling software resampling to 48khz/24bit, but still get pops and clicks during playback.

some other commands that will get the rev of your pi.
cat /proc/cpuinfo
cat /proc/device-tree/model

As there have been some issue reported on V1.5. Also try to upgrade to V3 as V2 is EOL. (Read the instructions carefully)
Make sure to use USB3, as the your DAC is an USB3 DAC.

Ok, I have Rev 1.4.

I initially had V3 installed, but a lot of plugins are missing from that as well, specifically GPIO Buttons, as I built a streamer box with a few buttons on it to control playback. MPD_OLED I can do manually, though the plugin makes it easier.

Will try USB 3 again, but earlier I got pops on that as well.

1 Like

I would advise to start with a fresh V3, GPIO-Buttons is pretty straight forward to install.
But first we need to get the audio OK, before adding plugins.
If on a fresh install the DAC is all ready producing pops/clicks, I’m afraid it’s related to missing drivers/not fully supported HW. But that is for Volumio to determine.

Alright, installed Volumio 3 with no plugins yet, all default sound settings. So far the sound is clean!

Now i’ll start adding plugins and retesting.

Is there a guide somewhere on how to install GPIO buttons in V3?

Edit: Spotify Connect is clean as well. And I found your post in the GPIO Buttons thread actually, so I’ll try that to get it installed.

So the only plugins you use are:

  • mpd_oled
  • Spotify
  • GPIO-Buttons

So install only one at the time and test. When all ok do the next,…

Thanks. So far so good with Spotify Connect + GPIO. Streaming through Spotify now and the sound is clean.

You think I can install MPD_OLED the same way as I did GPIO Buttons?


Follow instructions at the bottom of this topic. (3.5 MB) (331 Bytes)

1 Like

Ok, thanks.

And by the way, in Volumio 2 I had commented out “dtparam=i2c_arm=on”, and added “dtparam=i2c_vc=on”, to essentially move SDA/SCL from pins 3 and 5 to pins 27 and 28. Not sure if that could have cause the popping/clicking.

1 Like

No, I would not recommend it, but it should not give problems. I think soemthing went wrong with MPD_OLED installation.

Although the MOTU M4 has proprietary drivers it works as a class compliant audio device with no specific drivers. The drivers just offer some configuration flexibility that is not defined by the USB audio standards.