Cirrus Logic Audio Card Element 14

How can we get that awesome volumio release have support for our DAC Cirrus Logis Audio Card ???

Can anyone help me to make it work at least?

I only find instuctions and some images from few threats here about Wolfson Audio Card and rpi B (not new B+), but because are not targeted to the new hardware (rpi B+ and Cirrus Audio Card +) i tested that’s not working on rpi B+ with Cirrus Audio Card +.

I know that Cirrus Audio Card + … audio_card, have today a really weird driver integration and support to rpi understanding that most responsability for this are from Farnell and Wolfson :angry: , but i see that early version (Wolfson Audio Card) targeted to rpi B have at least a workarround to make Volumio working well and get it up and running, and i hope someone here can help to do the same with new improved version of that card to rpi B+.

I ask for help on Element 14 (Farnell) support site asking the same but with no result at today.

Any help to get volumio working will be really precied.

Thanks !

Updated RT-kernel for the Cirrus Logic Audio Card (kernel 3.12.33-rt)

Hi all.

I was looking into a way to use Volumio 1.55 with an RPi 2 and a Cirrus Logic DAC from Farnell/Element 14 (same as Wolfson card but with the big 40 pins connector for A+, B+ and 2)
I had to look around, I made some tests, it failed a lot of time and then it finally worked ! :slight_smile:

Here is how I made it work :

N.B. You will need internet access on the RPi2 during this procedure, but you can remove it after.

  1. Flash the official Volumio 1.55 image on a microSD card.

  2. Install the Cirrus Logic card and insert the microSD card in your RPi2.

  3. Start your RPi2 with official Volumio, configure network/system/etc. and verify it is working working well via HDMI sound or the low quality on-board jack A/V connector of the RPi2.

  4. Reboot your RPi 2.

  5. SSH into the RPi2 and become “root” (or use “sudo” in front of all commands).

  6. Type some command lines in order to add a kernel repository and upgrade you kernel (& modules) with one that includes the Wolfson/Cirrus Logic Driver :
    a) wget -q -O - | apt-key add -
    b) wget -q -O /etc/apt/sources.list.d/autostatic-audio-raspbian.list … pbian.list
    c) apt-get update
    d) apt-get install cirrus-config
    e) nano /etc/modules
    –> Here, you edit the file, you need to add a “#” in front of the “snd_bcm2835” line to disable the A/V jack audio driver, then “Ctrl-O” to save and “Ctrl-x” to exit.
    f) reboot

  7. The RPi2 will now reboot and the Cirrus Logic card should be recognized.

  8. SSH into the RPi2 and become “root”, again.

  9. Type some more commands :
    a) (to reset all settings on the cirrus Logic card)
    b) nano /etc/mdp.conf
    –> Here, you need to edit the “audio_output” section and make sure it looks like :
    audio_output {

                  type           "alsa"
                  name           "Output"
                  device         "hw:0,0"
                  mixer_control  "HPOUT2 Digital"
                  mixer_device   "hw:0"
                  mixer_index    "0"
                  dop    "no"}

    –> then do “Ctrl-O” to save and “Ctrl-x” to exit.
    c) (or another one from the Cirrus Logic scripts to confiugure the right output for you)
    d) reboot

  10. The RPi2 will now reboot again.

  11. Connect the cable to your amplifier or your headset on the Cirrus Logic card.

  12. Enjoy good music.

Of course, from now, do not change anything in Volumio that is related to I2S, DAC, Output, Hardware mixer, … it might break your working config.

You might need this :

  • user “volumio”, password “volumio”
  • user “root”, password “volumio”

This procedure worked for me on the 7th of March 2016, with an RPi2.
I have no idea if it will work for an A+ or a B+ RPi … or not.
I have no control on the content of the kernel package that is used, so it may well fail in the future if the owner of the repository decides to change anything.
Here is the link to the original message where I found information about the kernel repository : … 5&tstart=0

By the way, there are newer kernels with Wolfson/Cirrus Logic drivers included here :
… but I did not find a procedure to make them work with Volumio 1.55.

Hey Keldo!

Great write up! I’m trying to get the cirrus working myself on R2, but I get “ command not found” and
“ command not found”. Any tips?

By the way, it took me a while to find out how I became root: So for those looking on step 5), type “sudo -s” in the comand line to become root.

Hi Reidmyse.
This means you are missing the scripts from the original Cirrus/Wolfson driver package, or that the path to, or rights of, those scripts are incorrectly set.
Maybe I forgot to add a step to my procedure ?

Anyway, if they are missing, I think you can install them by following the last step (6) of this procedure : … g-the-code

By the way, usually, to become root, just type “su” and then give the root password. If you don’t know the root password but are allowed to use “sudo” then “sudo su” will do the trick… To come back as a normal user, type “exit”.
Don’t forget that, after typing “su”, you are root, so the home directory and the path may be different, all file you create will root as owner, etc.

I have a RPi 3 with a Cirrus DAC and untill recently I used this solution to get the card to work on Volumio.

When I tried the same for Volumio 2 RC hotfix the RPi wouldn’t even boot anymore. So I asked for some help, and fortunately the author of the page I mentioned above was really helpful and figured it out. You can find his solution at: